0

For a few days now my Macbook Air seems to hang for a second every five seconds or so. It is only noticeable in my browsers. Chrome, FF and Safari all have the same issue where the browser just locks up for a second before continuing. I looked in console and it is the same crash report being generated every five to ten seconds. The beginning of the log mentions a process x3d:

Process:               x3d [3646]
Path:                  /private/etc/.x3/x3d
Identifier:            x3d
Version:               ???
Code Type:             X86-64 (Native)
Parent Process:        launchd [1]
Responsible:           x3d [3646]
User ID:               0

Did some searching but came up empty handed. I've pasted the full log here:

http://pastebin.com/G9cTLFLR

The issue seems to go away if my computer is offline.

Does anyone have any idea what this is from?

Thanks in advance!

  • Do you use any Cakewalk products? A technical note they publish mentions X3D. – Graham Miln Jul 25 '16 at 14:19
  • no, I don't. I saw that as well but have never used or installed any of their products. – Normc Jul 25 '16 at 14:39
  • 1
    Try booting up in Safe Mode and see if it still shows up. – PoisonNinja Jul 25 '16 at 15:33
1

Try clearing all your cache files for your browsers. I was having the same issue with the same crash log for the last few days. I took it to the Apple Store for that and another unrelated issue with my display. They cleared out the cache folder for Chrome, and the issue quit just like that. No more freezing browser, no more crash logs. I was a little embarrassed I hadn't tried that, when I'd tried just about everything else I could think of. There seemed to be a chrome and/or x3d daemon that was hanging. Hopefully that will clear up your problem as well.

0

I hope you figured this problem out by now, but I had this issue with the x3 Watch accountability software. I had similar reports in my console, and discovered x3d was for the x3 Watch software daemon. Something was regularly crashing (like you mentioned, every 5-10 seconds) and really bogging my whole machine down, particularly on the browser (which makes sense - it's where the software functions most). Once I uninstalled the software, the problem was solved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .