17

The Documents folder on my Mac (macOS Sierra 10.12 beta) is not visible under my user in Finder. I can see the folder is there through Terminal

But in Finder, I can't see it:

enter image description here

I can see the folder in Finder under iCloud Drive:

enter image description here

Please help.

  • When you say macOS, you mean Sierra, right? Can you specify in your question? Just for clarification. – Munesawagi Jul 25 '16 at 2:32
  • @Angelplayer Done! – systemhalted Jul 25 '16 at 2:59
  • 2
    Did you turn on the iCloud Drive feature where Desktop and Documents are stored online? – NetherLinks Jul 25 '16 at 3:15
  • 1
    Yes. I did enable that. – systemhalted Jul 25 '16 at 3:23
12

This is a new feature in macOS Sierra. It allows you to put Desktop and Documents folder in iCloud Drive so you can access it in all of your Mac connected to that account and even iOS devices. You can disable it by pressing Apple Menu -> About this Mac, then go to storage and click Manage under Macintosh HD( or the name of your macOS partition) then in the iCloud part you can turn that feature off.

  • 3
    Can iCloud folders be unhidden without disabling iCloud sync? Why are they hidden in Finder, but visible in Terminal? – jtheletter Nov 27 '18 at 18:46
  • 2
    There should be a way to solve this without disabling iCloud. It seems overkill to disable that service just so we can find a folder. – Mig82 May 31 at 11:34
  • 1
    I'm very confused about this. Is the Documents folder actually on the local hard drive or just on iCloud? – dylnan Jul 1 at 23:46
5

Check the "iCloud Drive" under iCloud in the Finder window sidebar. There may be a visible Documents folder there.

  • 1
    this answer helped me finding the folders – Naveed Ahmad May 15 '17 at 6:17
4

What I did was creating an alias of those folder on the same directory so I can see them from my home folder.

aliases

  • I did this same thing. It works great and I get to keep iCloud enabled. This should be the accepted answer. Creating an alias is also super-simple to do. – Mig82 May 31 at 11:35
3

I had the hidden Documents folder too. It showed up in sidebar, but not in my user directory. I had to move all my files and folders within my Documents folder to a different folder, say on my Desktop, then completely delete the Documents folder using Terminal. sudo rm -r Documents/ As soon as it deleted, it was immediately recreated, and now visible. I then just moved everything all back.

  • 1
    Your answer helps when you have turn off using iCloud for Documents. I turned it off, play around, and then my Documents were in my home, but when I drag-drop Documents to the Finder bar, it disappeared immediately. – hectorpal Jun 6 '17 at 19:39
2

While I'm not sure what the reason is (maybe a beta glitch or temporary decision), you should be able to work around it by using the Go To Folder command in the Finder and entering ~/Documents. Then drag it to the Favorites sidebar and you can always access it from there.

  • 1
    No need to drag to Favorites. Already there should be both Desktop and Documents in the the sidebar; alongside iCloud, click Show. – Graham Perrin Aug 13 '16 at 18:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .