-1

I tried updating ruby and this was my feedback

tried a sudo install and this was my feedback I have all the pac managers and etc that i can get from any book or online resources anywhere, ive tried many methods and just about everything i can find online. Can someone who knows exactly what the issue is inform me on the solution.

  • Did you read the error message that says you need Ruby 2.2.2 or newer? Run ruby --version if you need to check. – NetherLinks Jul 22 '16 at 3:40
  • 1
    When you post output, please don't take a screenshot unless absolutely necessary. It's better to cut and paste code into your original quesiton. – Allan Jul 22 '16 at 3:51
1

You need to update Ruby.

  1. Install home-brew (It will allow you to install software package from source): ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

  2. Install ruby:

    • brew install rbenv ruby-build
    • echo 'if which rbenv > /dev/null; then eval "$(rbenv init -)"; fi' >> ~/.bash_profile
    • source ~/.bash_profile
    • rbenv install 2.3.1
    • rbenv global 2.3.1
  3. Check which version you have (It should show 2.3.1): ruby -v

  4. Install Rails:

    • gem install rails -v 4.2.6
    • rbenv rehash
  5. Check Rails Version: rails -v

I hope it helps you

Source

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .