0

I have joined my home WiFi network and I don't get Internet through it anymore. Phones and other computers have no issues, others who were here haven't changed anything or noticed any difference.

I was away from home for a week using various public and hotel WiFi networks, if that means anything. I used a public WiFi network 30 minutes before and had no issues.

I've looked through previous questions like this which had a lot of responses, and I still haven't solved it:

Full Wi-fi/ethernet signal but no internet

How do I troubleshoot my Wi-Fi connection when an exclamation mark appears?

I can log in to the router admin settings. Everything seems fine. I have tried changing the IPv4 address manually, making sure nothing is using the same IP etc.

I have tried using 8.8.8.8 as the DNS server address. In Terminal ifconfig en1 gives:

Flags=963<UP BROADCAST SMART RUNNING PROMISC SIMPLEX> mtu 1500
Options =60 <tso4, tso6>
Ether 4a:00:03:a0:13:90
Media: auto select <full-duplex>
Status: inactive 

(Apologies if the syntax is off, I'm copying this on to my phone)

It is a MacBook Pro retina 13inch 2.9ghz i5, OSX 10.11.4

Any ideas are much appreciated!

1

Your wireless device appears to be in promiscuous mode. Maybe you are doing a packet dump or sniffing packets? If so, no worries. If not, I would investigate this further, as it sometimes yet not always indicates a compromised system being used as a stepping stone in further network penetration.

First, a quick and dirty network device refresh can be effectuated by creating a new location in the System Preferences, under the network portion. Look at the top, and under location, click edit locations. Then click the plus button, and give the new location a name.
Then please select your home network, and re-enter the password.

Your problem might have been resolved. If not, then please go back to the terminal and provide the output of these:

     ifconfig -a -v

     pfctl -v -si

     pfctl -v -sr

     ipconfig getpacket en1

     netstat -nvia -I en1

     netstat -nr

Hope that this helps.

F.

  • I am not sniffing packets as far as I know. I tried the new location suggestion but it did not help. I have the terminal outputs for the commands you gave but I will have to wait until tomorrow to get to a computer that I can post from. Thank you for your help. – dx99 Jul 22 '16 at 4:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .