0

Short problem background

OS X version 10.10.5, running on an iMac with no problem (uptime = 101 days). I had an USB key, named "Free" mounted on /Volumes/Free. I wrote successfully a file on it, and verified it successfully with Disk Utility. Then I tried to eject it from the Finder. This operation fired the beach balloon but no message was written on /var/log/system.log. After a while the Finder displayed me an error message telling me my volume couldn't be ejected because in use.

Since I needed the USB slot to restart the copy operation on another USB key, I ejected my USB key "Free". And the Finder displayed me the usual error message because the volume was unmounted incorrectly.

Problem seen actually

I have now a directory /Volumes/Free which stayed in place and which I can't easily remove.

••On_my_Mac••% ls -@del /Volumes/Free
d--x--x--x+ 2 root  admin  102 Jul 11 14:01 /Volumes/Free
 0: group:everyone inherited deny add_file,add_subdirectory,directory_inherit
••On_my_Mac••% 

Neither Spotlight nor any other daemon stayed with this directory opened:

••On_my_Mac••% /usr/bin/sudo lsof /Volumes/Free
••On_my_Mac••%

Nonetheless I get the following error upon trying to remove it:

••On_my_Mac••% /usr/bin/sudo rm -rf /Volumes/Free
rm: /Volumes/Free/.autodiskmounted: Permission denied
rm: /Volumes/Free: Permission denied
••On_my_Mac••%

If I further try to analyze this filesystem problem, I get:

••On_my_Mac••% /usr/bin/sudo chmod u+rw /Volumes/Free
••On_my_Mac••% /usr/bin/sudo ls -@ael /Volumes/Free
ls: fts_read: Permission denied
••On_my_Mac••% /usr/bin/sudo ls -@del /Volumes/Free/.autodiskmounted
-rw-r--r--  1 root  admin  0 Jul 11 14:01 /Volumes/Free/.autodiskmounted
••On_my_Mac••%

I didn't try a reboot because this is not a short term an option on the server involved.


Which daemon is responsible of this situation?

How may I further analyze this problem?

  • 1
    What's the output of: ls -@el /Volumes/Free/.autodiskmounted – user3439894 Jul 23 '16 at 12:54
1

You tried the command given below.

/usr/bin/sudo rm -rf /Volumes/Free

Try entering the following.

sudo sh
/System/Library/Extensions/TMSafetyNet.kext/Contents/Helpers/bypass rm -rf /Volumes/Free
exit
| improve this answer | |
  • This command is giving the same error:••return•• rm: /Volumes/Free/.autodiskmounted: Permission denied••return•• rm: /Volumes/Free: Permission denied – dan Jul 22 '16 at 14:53
  • BTW, what should do this bypass command? – dan Jul 23 '16 at 13:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .