1

We have a Virgin Media cable provider and most of our neighbours are Sky or BT. All available networks appear in the drop-down on the top menu and indicate if they are secure or not. Ours is the strongest signal, yet repeatedly it is pushed to the bottom of this list and my Mac tries to join a BT one.

I want to just remove all these BT and Sky Wi-Fis so the Mac always defaults to our provider and never tries to connect to them, but solutions supplied elsewhere don't apply.

When I go to the Advanced menu on the WiFi preferences, these BT and Sky options aren't there. How do I get them off the dropdown menu or just tell Mac to ignore them permanently?

2

Have you tried System Prefs > Network > WiFi

Switch off 'Ask to join new networks', then in the Advanced... section below, you can drag networks into your preferred order & delete ones you no longer wish the machine to remember [this will tie in with 'Ask to join...' & shouldn't bother you again].

enter image description here

| improve this answer | |
0

Doing that has no effect. The order in which networks appear reshuffles every time I open the Mac. None of the networks in my street (except our own) appear in that list

It feels as if, when I open my MacBook, it just connects with the first one it finds and then tries to log me in. Then it seems Virgin is slowest as it's always last on the list

It's not impossible because I manually select it and that puts it back at the top but it's annoying when it connects to next doors unsecured network and I don't spot it straight away

As an aside I'm frankly sick of BT and would like an 'ignore everything beginning BT' option on phone and Mac but that's another story

| improve this answer | |
  • Welcome to ask different. Please don't add comments as answers. When you have sufficient reputation, you can add comments, however, what is actually best here is if you update your original question. Take a look at the How to Answer in the Help Center I am upvoting your question to get some points on your scoreboard..... – Allan Jul 22 '16 at 14:13
0

It feels as if, when I open my MacBook, it just connects with the first one it finds and then tries to log me in.

Turning off "Ask to join new networks" while turning on "Remember networks this computer has joined" should allow your computer to automatically join your home network and any other networks listed as "Preferred."

When I go to the Advanced menu on the WiFi preferences, these BT and Sky options aren't there. How do I get them off the dropdown menu or just tell Mac to ignore them permanently?

I don't believe you can remove available wifi connections from that dropdown menu. But if none of these networks are listed in your "Preferred," and your computer is now connecting, automatically to your home network, you can ignore these other networks as there should be no need to use the menu bar's dropdown list.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .