1

I created an automator workflow and saved it as a workflow. When I test it from within automator, the workflow works. But when I try to run it from the command line (automator path/to/workflow), I get the following:

No application name for definition at URL file:///Library/Automator/Office.definition/

Failed to load definition at URL file:///Library/Automator/Office.definition/

No application name for definition at URL file:///Library/Automator/Office.definition/

My ultimate goal was to run this workflow with Lingon, so that I can schedule it. (Lingon throws the same errors).

I also tried saving it as an application and then running the Application Stub, but I get the same errors.

What am I doing wrong?

Update:

Here's the screenshot of the actual workflow. enter image description here

  • A screenshot of the workflow might be helpful so we can try and reproduce the error to debug it. – user3439894 Jul 20 '16 at 17:00
  • I added the screenshot, I didn't think it was related to the actual workflow since it the workflow works without errors when running it from within automator. – gdaniel Jul 20 '16 at 17:07
0

I made an Automator workflow, using the Actions shown in your screenshot, and saved it as an application named CopyFiles.app in the /Applications folder. In Terminal I typed open -a CopyFiles then pressed enter and it ran as expected creating a copy of the files to the designated location.

Next, using Lingon X, I created a new Launch Agent to run the open -a CopyFiles command at a set date and time, so I could test that it works, and it triggered at the set date and time and copied the files to the designated location, as expected.

  • So this works. I don't know why running the actual automator command doesn't work... also lingon "choose" button was automatically looking for the Application Stub inside the app package, which was also not working. But using the open command works. So thank you very much. – gdaniel Jul 20 '16 at 18:03
  • @gdaniel, With AppleScript and Automator applications, in cases such as this, I personally prefer to use the open -a $app_name syntax however I did just now test the Launch Agent using /Applications/CopyFiles.app/Contents/MacOS/Application\ Stub and it too worked. I also tried it without escaping the space in the command line with a backslash and just quoting the fully qualified pathname and it too worked. I did not test the process saved as a .workflow as that requires opening the Automator application and manually running the workflow, which defeats the purpose in this case I'd assume. – user3439894 Jul 20 '16 at 18:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .