0

Good day everyone. For only 1 hour (!) I used my relatives iPhone with my sim card and that's it, he keeps receiving all of my iMessages. I tried checking in iTunes all devices associated with my account and his device is not listed. I tried to log in and log out to/from iMessage on his phone with his apple ID, still won't help. How can I stop this nightmare!? When I go to iMessage settings>Send & Receive on his device, there is only my phone number listed, how do I remove it without smashing phone to the wall?! Thanks and have a great day

EDIT. After talking to apple support for some time, they removed my phone number from my friend's iMessage. So I guess if you are facing same problem you have to contact support.

  • Have him check his "Send and Receive Devices" and make sure your phone number is not listed. – TMHahn Jul 19 '16 at 15:53
  • That's exactly my question: "... When I go to iMessage settings>Send & Receive on his device, there is only my phone number listed, how do I remove it".. – G.M Jul 19 '16 at 15:55
  • I'm sorry, I misunderstood. Does he have an email address listed, too? – TMHahn Jul 19 '16 at 15:56
  • We have logged in and out several times, ATM it's not listed – G.M Jul 19 '16 at 15:58
  • 1
    Did you try by chance to use Apple's Deregister iMessage service? selfsolve.apple.com/deregister-imessage – Pinchus G. Jul 19 '16 at 16:23
3

Following the instructions on Apple's Deregister iMessage should help you resolve this issue.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .