Sorry if my question is easy because I am new to Mac.

OS X Yosemite on my friend's Macbook Air was removed. Now when we start his Mac it has just Windows.

For installing Os x, I got the the installation file (13 Zip file) from third party web site and extracted that and it produced dmg file.

Now I have tried to made a bootable USB of OS X Yosemite with my Mac by using Disk Maker App.

Now when we turn on Mac of my friend while pressing Alt , I can see the icon to install Yosemite. So I click on that and continue first steps like language without error, but after 2 or 3 steps I received error

" This copy of the Install OS X Yosemite application canโ€™t be verified. It may have been corrupted or tampered with during downloading."

Please help what is the problem and how i can solve that.

  • I am not a fan of using those Apps since it's so easy to create a USB installer. Download the installer from the App Store then just follow the instructions Create a bootable installer for OS X This way, you are 100% certain that you downloaded a genuine version of OS X from Apple.
    – Allan
    Commented Jul 18, 2016 at 22:52
  • You can bypass the check via the command line. See answer for similar El Capitan question: apple.stackexchange.com/questions/216730/… Commented Oct 16, 2018 at 0:48

3 Answers 3


Your installation file for Yosemite has had its digital certificate expire. Which means after a certain date it will no longer work. To work around this issue you open the Date & Time preferences pane, uncheck the box for "Set date & time automatically" & set the date back to just after the time Yosemite was initially released (October 16, 2014) then run the installer.

  • 11
    Thank. You. Soooooo. Much. In the installation menu, choose Utilities / Terminal and type date 1020170014 then quit Terminal and the installer works.
    – mvreijn
    Commented Oct 29, 2016 at 15:13
  • 4
    This achieved the opposite in my case. Yosemite refused to installed specifically because the date was wrong and setting it to 1020170014 in terminal changed nothing. Changing the date to today (aug 2017, long past the expiry date) allowed the installation to proceed.
    – stef
    Commented Aug 26, 2017 at 18:00
  • 1
    @stef- Thanks for the update. I'll have to keep this new development in long term memory in case I run into this re-install challenge in the future.
    – KarlC
    Commented Aug 29, 2017 at 21:04
  • I have now used this trick several times to put Yosemite on older hardware. The date window is fairly long -- over a year. I usually use 1 jan 2015. You can set the date in the system preferences pane. You may need to uncheck 'set date automatically' After the install check the set date automatically again to sync with world time. Commented Jun 23, 2018 at 12:11
  • Yes like stef the first suggestion didnt work, either because A) I replaced the battery while the case was open (installing a new HDD) or B) I installed from a USB drive where the dates of the install files was later than the clock date. I set the date using terminal, to the current date and time according to these instructions and it worked fine. bensmann.no/changing-system-date-from-terminal-os-x-recovery Commented Dec 26, 2018 at 5:50

"Sorry if this question is easy" ๐Ÿ˜‚๐Ÿ˜‚๐Ÿ˜‚ that one really cracked me up ๐Ÿ˜‚๐Ÿ˜‚๐Ÿ˜‚๐Ÿ˜‚
You don't need to be sorry, any question is welcome :)

Well, it's actually a tricky one, since (sadly) that's a really unspecific error. It can be caused by many things. Though I guess it's not a filesystem error, since the installer booted up fine. So that's one reason out.

  • The first thing you should check (and add to your question please) is: Where did you get the installation file (ISO/DMG) from? Is it an official distribution from the App Store, or did it come from a third-party source (a pirating website maybe?). The reason that's important is that ol' uncle Apple are extremely annoying with their security. And I mean, extremely. No access to system files on iOS type of extremely. Now that's (as always :P) a problem here, since if the installation didn't come from a first-party source (aka the App Store), then it might not be properly codesigned (I explained a bit about codesigning below). So please edit your question so it specifies the source if the installation so I can help you further.

  • Another reason for your problem might just be that the installation is, as specified, corrupted. What does that mean? Well, a lot of times when burning files to a disk (e.g. burning an ISO to a USB drive), there might be a tiny error (maybe even a single corrupted byte) that will just ruin the structure of the whole file. Annoying, isn't it? This can be caused by many reasons. Maybe your file is bad, maybe your disk is bad, maybe your disk maker is bad (in which case I really suggest you try a personal favorite of mine called Rufus, which is also completely free, though sadly it's only available for Windows, so try to get your hands on one for a few minutes), and maybe it just happened randomly (yep, that happens. Bummer.). Go through option one, then if you have a legit, official copy of the installer, check your disk, then just try to burn the installer again. If it still doesn't work, switch to a different disk maker application.


So codesigning (code-signing) is pretty much a standard when it comes to Apple systems (macOS/OS X, iOS, etc.). It's something that is really awesome but also really annoying at the same time. From Wikipedia:

Code signing is the process of digitally signing executables and scripts to confirm the software author and guarantee that the code has not been altered or corrupted since it was signed. The process employs the use of a cryptographic hash to validate authenticity and integrity.

So, as I said, it's a pretty neat idea. It's basically a little encrypted string embedded in the software code, that approves that this is the official code, from the official developer, and that it should run just like it's supposed (assuming you meet the system requirements). You can think of it just like a signature: When you see the author's signature on a document, you can be sure that it's his, and that it's original and official. And just like a signature, it's unique and hard to fake. But the problem is that it causes a lot of trouble when a developer doesn't properly sign his code. For example, I tried to use GDB (the GNU Debugger) the other day, and it didn't work due to inappropriate codesigning. Even though, for the most part, it's up to the developer to be responsible for properly signing his code, it's still pretty important to understand what it is, at least in a general, basic level.


This happened to me too, and I simply re-downloaded the Yosemite installer using the App Store.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .