0

The Wi-Fi where I work is spotty at times and spotty in certain locations (like where my cube is :-( ). I won't get into why it's still like this after months of complaining but I want to use the USB Ethernet at my desk since it's more reliable and then fail over to Wi-Fi if I unplug the USB to go to meetings or something.

I found this link on the apple stackexchange site but it's not doing what I think it should be doing, which is connect in the order specified in System Preferences. It appears that it's connecting to both and using both sources (Wi-Fi more than USB).

In this screenshot, we can see my System Preferences. USB is first, Wi-Fi is second. this screenshot

In this screenshot, we can see via iStat Menus that both interfaces are receiving traffic, although, most traffic has been going thru Wi-Fi even though I've been plugged into USB for about the past 45 min to 1 hr. Hopefully there's a way to connect strictly via USB when I'm at my desk and Wi-Fi when I move around.

this screenshot

2

The problem is that you are on two different subnets with two different gateways.

enter image description here

enter image description here

What's happening is that you have an established connection with some endpoint going to a particular IP address. Your internal network firewalls switches and routers all have this state mapped.

When you go from WiFi to your desktop USB connection, your Macbook wants to keep it's active connections, well, active. So, it will continue to download over the connection with the active state.

As far as OS X and your applications know, you are on two totally different networks. While the USB may take priority (for new connections), it can't override other connections with active states.

The easiest way to resolve this is to simply turn off WiFi when you get to your desk then turn it on when you leave.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .