0

I'm running OS X 10.11.5, and try to start Microsoft Lync 2011.

When trying to start the Lync application, it directly just exits. I see following log messages:

2016-07-18 15:32:49,309 sandboxd[149]: ([5745]) Microsoft Lync(5745) System Policy: deny file-ioctl /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/Resources/HIToolbox.rsrc
2016-07-18 15:32:49,329 sandboxd[149]: ([5745]) Microsoft Lync(5745) System Policy: deny file-ioctl /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/Resources/English.lproj/Localized.rsrc
2016-07-18 15:32:49,346 sandboxd[149]: ([5745]) Microsoft Lync(5745) System Policy: deny file-ioctl /System/Library/Frameworks/QuickTime.framework/Versions/A/Resources/QuickTime.rsrc
2016-07-18 15:32:49,362 sandboxd[149]: ([5745]) Microsoft Lync(5745) System Policy: deny file-ioctl /System/Library/Frameworks/QuickTime.framework/Versions/A/Resources/English.lproj/Localized.rsrc

Any ideas on how to fix this? Do I need to configure SIP to allow for this, and if so, any tips about how I do that would be appreciated.

  • Which version of Lync are you using? – Allan Jul 18 '16 at 17:48
  • Latest version of Lync 2011, which is 14.4.1. – MartinF Jul 18 '16 at 17:49
  • I was reading somewhere (trying to find it) about this problem and one of the solutions was to repair disk permissions. Have you tried that? – Allan Jul 18 '16 at 17:59
  • That a relatively new release (July 2016). It may have broken something. Best thing to do is to contact Microsoft. support.microsoft.com/en-us/kb/3175174#bookmark-issue – Allan Jul 18 '16 at 18:06
  • I've done repair permissions, but it didn't help (none of the referred files were "repaired" anyway). I'm currently trying to register an issue with Microsoft, but haven't succeeded yet (they send me around, but I'm sure I'll land soon...:D). – MartinF Jul 20 '16 at 18:20
1

Installing the "OS X El Capitan 10.11.6" Update fixed the issue. This is perhaps not a proper answer, since I still don't know the underlying cause, but I post it anyway since it points to the cause being configuration of OSX and not a problem with Lync. Since it was fixed by the upgrade, I most probably could have configured my previous version of OSX (10.11.5) to fix it but I don't know how.

0

I also noticed the error log of Lync. I thought disable SIP would help. I tried and the log changed to:

Sandbox: Microsoft Lync(608) System Policy: allow(0) file-ioctl /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/Resources/HIToolbox.rsrc
Sandbox: Microsoft Lync(608) System Policy: allow(0) file-ioctl /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/Resources/English.lproj/Localized.rsrc
Sandbox: Microsoft Lync(608) System Policy: allow(0) file-ioctl /System/Library/Frameworks/QuickTime.framework/Versions/A/Resources/QuickTime.rsrc
Sandbox: Microsoft Lync(608) System Policy: allow(0) file-ioctl /System/Library/Frameworks/QuickTime.framework/Versions/A/Resources/English.lproj/Localized.rsrc

Actually, I don't see any different behavior of lync with this change.

To disable/enable SIP, see the System Integrity Protection. You have to boot to recovery mode before do it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .