2

I followed what reported on Use Handoff in Chrome for iOS to use Handoff to be able to use Handoff with Google Chrome between my iPad and my Mac Mini.

  • I connected both devices to the same Wi-Fi network
  • I signed in to iCloud with the same account on both devices
  • I turned on Bluetooth and paired both devices
  • I turned on Handoff
  • I enabled Handoff on Google Chome, which is the default browser on my Mac.

Yet, Handoff doesn't allow me to continue browsing on my Mac Mini a site I open on my iPad. I also tried moving away from my Mac and returning with a new page open, but that didn't work. Even setting Safari as default browser and opening a site with Safari on my iPad didn't help.

Handoff was working normally, even if my iPad and my Mac were not paired through Bluetooth, before I connected my Mac to Internet via Ethernet cable. Once I connected it back via Wi-fi, Handoff stopped working, even after resetting my Mac.

How can I make Handoff work again?

I paired the devices via Bluetooth only after I noticed Handoff was not working as before, once I started again to use the Wi-Fi.

You must log in to answer this question.

Browse other questions tagged .