1

I know there are similar questions on the site, but I'm not quite seeing an answer that works for my network.

I work in a hospital, and we have a guest network that uses a captive portal forcing the user to accept terms before use. On iOS devices, this network connects without issue. The Apple Captive Network Assistant (or whatever its equivalent on iOS is called) pops up and shows the portal page.

Using my Macbook Air running the latest version of El Capitan, I get very inconsistent results connecting to this network. I immediately get a connection to the WiFi network, but I do not consistently get the pop-up for the portal to accept terms. I also cannot force the page, either. I have tried entering into Safari http://captive.apple.com/hotspot-detect.html. I've tried 1.1.1.1 which is the address that pops up with the captive portal. None of these work.

I have also tried to delete my network preference files. I have tried to manually assign a DNS server 8.8.8.8, etc.

None of these things seems to work.

Sometimes, shutting down and restarting the computer works. (Software restarts do not typically work). Or, occasionally letting the computer sit connected for upwards of 30 minutes it will suddenly connect.

Why would I be able to connect to the network on iOS and an Amazon FireStick without issue, but not OS X?

1

One more thing that you may try that works fairly consistently for me. Under Network Preferences, change Location to some other, if this is the first time you do this, do "Edit Locations" and press the "+" sign and add one using any name you like, copy any old settings that may apply. Apply them, and "Hey, presto!" you get the log-in screen of your internet service.

Hope this helps.

  • I accepted this as the answer because it is as close as a good answer as I've gotten. It doesn't work 100% of the time, but since I've done this, I've had a lot less trouble connecting to the captive portal. In addition, much of the time it hasn't even been asking me to confirm on the portal. So, thanks. – David M Jul 29 '16 at 15:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .