37

I'd like to know how to increase the font size for Eclipse so it adjusts the whole GUI to not look so darn small on my screen.

For NetBeans there is the --font-size switch which can be set in netbeans.conf, is there something similar for Eclipse?

(In case it's useful, I'm on Snow Leopard.)

11 Answers 11

32

Inside the Eclipse.app is a setting for the font size. To make the fonts globally larger edit Eclipse.app » Contents » Eclipse » eclipse.ini and remove the line

-Dorg.eclipse.swt.internal.carbon.smallFonts

from the file. Save the file and restart Eclipse.

  • 2
    This actually helps, nice one! – Henrique Ordine Sep 20 '14 at 10:58
  • 1
    Great. This solves also the small size of the interface elements, like the Package Explorer. I was turning blind before... BTW, you know what's fine? I have such line in my eclipse.ini twice, one was commented out and the other not. I wonder why the did that... – Fran Marzoa Nov 11 '14 at 17:09
  • 2
    In Mars it's located in Eclipse.app/Contents/Eclipse/eclipse.ini Also, I found two lines in the .ini file that had this -D definition, so make sure to remove all of them before restart. – andrewz Aug 24 '15 at 13:48
  • This should be the accepted answer. This is the only way to increase the GUI fonts in Eclipse on OS X that I've found. – toolbear Apr 29 '16 at 19:26
  • 3
    In Neon, the .ini file is also in /Applications/Eclipse.app/Contents/Eclipse/eclipse.ini just like @andrewz commented. Also, there are two lines in the .ini file as well, which you have to remove. – adino Jul 22 '16 at 16:36
36

Go to Preferences > General > Appearance > Colors and Fonts, expand the "Basic" folder and select "Text Font" and change that to whatever size you like.

For Eclipse Neon: To Increase Ctrl + To reduce Ctrl - for Macs, use the command key, not the control key

shortcut for font eclipse

  • 1
    Does not work at all. I am using Kelper on yosemite. – Alex Mar 18 '15 at 16:19
  • 2
    This only changes the text font. It has no impact on the GUI globally as the OP asked. – toolbear Apr 29 '16 at 19:16
  • 1
    ctrl shift + also works an was the only way for me to zoom in (eclipse 7.2) – PeterM Jul 4 '17 at 10:33
7

As far as I know, there's no way to increase the font globally. In Eclipse's Preferences, navigate to General > Appearance > Colors and Fonts.

Dialog font is the font used in the dialogs, and Text Font used in text editors, etc.

I don't know how to increase the font for the rest of the GUI, though.

  • @MichaelLange see my reply. – akuhn May 19 '12 at 8:14
  • This is a reasonable compromise for me. Eclipse uses so much screen estate on GUI-fluff that this is the only reasonable way to get a lot of information on there too. – Thorbjørn Ravn Andersen Dec 17 '12 at 12:13
4

Solution for Eclipse Oxygen at MacOS High Sierra (Dec 2017)

  1. Open terminal and run commands:

    cd /Applications/Eclipse.app/Contents/Eclipse/plugins/org.eclipse.ui.themes_1.2.1.v20170809-1435/css
    
    vim e4_basestyle.css
    
  2. Add a style:

    * {
        font-size: 14;
    }
    
  3. Restart Eclipse to apply changes.

  • 1
    I hope it is allowed here to remark that this solutions also works on Eclipse Oxygen Linux. The file is in plugins/org.eclipse.ui.themes_1.2.1.v20170809-1435/css I have used font-size: 24; on my screen (since it is a bit higher DPI than the retina Macs) – mak Mar 7 '18 at 9:51
3

For eclipse luna : edit eclipse/plugins/org.eclipse.ui.themes_1.0.1.v20141126-1957/css/e4_default_gtk.css

and add at end of file :

* {
  font-size:14;
} 

This will make eclipse keep same font if you switch workspaces

  • I've edited /Applications/Eclipse.app/Contents/Eclipse/plugins/org.eclipse.ui.themes_1.1.300.v20161107-1827/css/e4_basestyle.css and it works on Sierra! – cahn Mar 27 '17 at 2:13
0

I have Eclipse installed in a Linux machine. A while ago I did a Linux update and it messed up the fonts on the entire system. All the fonts got larger. So, I went all over the place resizing the fonts for each application.

Guess what?! On the next Linux update, the fonts got back to normal. However, I had to go back and undo all the font resizing that I had previously done on every application. So, when it came time to reset the fonts in Eclipse, I couldn't remember exactly what I did. I went to the following location:

Window > Preferences > General > Appearance > Colors and Fonts > Basic > Text Font > Edit

No matter what I did on this setting, the font remained the same.

I finally figured out what the problem was. I had also resized the fonts on the following location:

Window > Preferences > General > Appearance > Colors and Fonts > Structured Text Editors > Structured Text Editor Text Font (overrides default: Text Font) > Edit

Once I edited this setting, the fonts on Eclipse went back to normal.

0

NOTE: For those coming from Google, this change has no effect on later MacOS/Eclipse versions of El Capitan and Mars, respectively. See this related question: Yosemite: How do increase font size of Eclipse globally?

  • Removing the smallfonts option from the eclipse.ini file worked fine for me in Neon on Sierra. Are you sure you removed both occurrences of the option from the file? – Ward Muylaert Jun 1 '17 at 9:22
  • The font size increase is very subtle. Take a screenshot before/after and compare. – wisbucky Jul 11 '17 at 19:54
0

You go to colors and font and go to the java drop down and find java editor and edit the size and it should work as it has for me.

0

eclipse on Mac, for the font in the tools bar, you have to go to the system preference->display->resolution, and change the system font.

0

window --> preference-->general-->apperance-->colors and fonts-->basic -->text font

0

Menu: window -> editor -> zoom in/out

You must log in to answer this question.

protected by Community Jan 3 at 15:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .