3

Every time I try to login with my usual username (i.e. gsamaras), I get a pop-up, like a suggestion from my Mac, for the word samaras, so unless I click on the x button, "gsamaras" will be replaced by "samaras".

How can I tell my Mac not to correct gsamaras?

Note: Formatting the laptop is not an option.

  • When you say "login," do you mean logging into your Mac itself or into Ask Different? – aaplmath Jul 15 '16 at 20:01
  • Once logged in, can you try this: Open text edit, type your name, right click and pick "Learn Spelling". Maybe that will add it to a system wide dictionary? Also, maybe try to have it Learn Spelling from the login screen? – joels Jul 15 '16 at 20:11
  • @joels I don't believe it's a system dictionary, but rather a user-specific one (it's inside ~/Library). However, if this need only apply to one user account, that should probably suffice. – aaplmath Jul 15 '16 at 20:13
  • I mean when logging into my email for example, sorry! @joels that did the trick, I suggest you post an answer! :) – gsamaras Jul 15 '16 at 21:24
6

Type your name, right click and pick "Learn Spelling".

1

You can add the word to your dictionary or you can disable auto correct. Go up to Edit -> Spelling and Grammar, then untick Correct Spelling Automatically.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .