0

I own both an iPhone and a MacBook. I have disabled iMessages on the iPhone and I prefer to keep it this way. I employ the latest versions of both iOS and OS X.

When I send SMS text messages from my iPhone to contacts who also use iPhones their replies arrive on the MacBook (in its Messages application) but not on the iPhone.

I suspect this could be the case because those contacts have iMessages enabled and so their replies get routed by default to a device of mine which supports it as well (i.e. my MacBook but not the iPhone).

Is there a way to remedy the situation without me having to enable iMessages on the iPhone? (I don’t care for iMessages over SMS and I would like to receive all text messages on the iPhone.)

  • 2
    I'd love to know why you disable it? Maybe we can find an alternative for you... – emotality Jul 15 '16 at 14:06
  • @emotality It's just a hunch. SMS is a simple concept, short pieces of text between two phone nos. and that's it. iMessages, on the other hand, get routed and copied between co-owned devices in all kinds of ways and travel with additional metadata. Opposite some phone nos. I prefer to keep it "simple" (even though they might use iPhones too), i.e. stricly send them SMS only. It might not seem elegant, but since I currently have no use for the more fancy stuff Apple provides over SMS doing this in iMessages (the app) would seem like a possible way to go (minus the current routing problem). – Drux Jul 16 '16 at 4:02
1

If their reply is in blue, it's an iMessage, and you disabled iMessage, so it won't come through. If the message is in green it is an SMS, which will always come through. The only way around it is to disable iMessage on all your devices so that your friends' iPhones don't pick you up as iMessage-enabled contact and hopefully send you SMS instead of iMessage. If the iMessage didn't went through they can touch and hold the blue message and tap "Send as text message" to send as SMS.

So the solutions are to enable or disable iMessage on all your devices. I'll go with enable, because you have nothing to lose and makes life easier for everyone and yourself.

If you really don't want to enable iMessage on your phone, at least narrow down the emails/numbers where one can get to you. (if that is the reason why you don't want iMsg??)

  • How does one disable iMessage on OS X? I'd also like to test the following lesser alternative (but now applicable message was sent yet): In iMessages on OS X under preferences, deselect "You can be reached for messages at: <phone no.>". – Drux Jul 16 '16 at 3:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .