1

I'm in the process of upgrading a test box to El Capitan and have run into some strange behavior with what may be network NFS share permissions?

Background info:

We currently authenticate to a 2008 AD server and use NFS shares to mount to the server.

Example issue:

One issue that keeps popping up is the use of an AppleScript to jump to a shared network folder. If I bind the workstation to the AD server, log out, then log back in as a network user. The AS works just fine.

If the workstation is rebooted we get this error when running the AS:

Finder got an error: Can't set disk to "pool1" to folder "test" of folder "project" of folder "account" of disk "pool1".

Unbinding and rebinding the box, will fix the issue until reboot.

Same setup on 10.8.5 works fine.

I tried to disable SIP, thinking that something may be getting overwritten on reboot but that does not seem to be the case.

Edit to add more info / respond to questions:

  • ActionScript should have been AppleScript. I've made the correction above.
  • I do see some write permissions with Adobe CC tools. Adobe Photoshop CC 2016 could not save an update to a file. The first file save was fine then I'd have to change the name to save again. Downgrading to CS6 solved this issue.
  • By bind/unbind yes I mean adding and removing the box from the AD via OSX Directory Utility
  • Mounting via autofs/auto_nfs
  • Mounts are in /Volumes
  • Auth via ACLs
  • I dont think SIP is involved at all. What would be interesting to see is if it fails if you. 1) Have the machine bound and working. 2) Reboot. 3) Login as a local admin first. (and try the AS here) 4) logout from local user 5) Login as a AD user. (try the AS again, without rebooting and rebinding.) It would also be interesting to see what error message terminal: mount has to say, both to see if the nfs path is already mounted or not, and also to try and mount it using terminal, it can be a bit more verbose. – Niklas Jul 16 '16 at 13:10
  • Also does it work with another AD user, when its working, can you logout and login as a different user and run the AS? – Niklas Jul 16 '16 at 13:14

You must log in to answer this question.

Browse other questions tagged .