I am trying to boot a Yosemite VM (10.10.5) following these instructions here.

But it gets stuck in a loop at the BIOS boot screen (the OS has not yet been installed)

My hardware is a Mac mini with Ubuntu 14.04 installed (I specifically need to use KVM to boot OS X VMs for my use case), hardware is:
CPU: GenuineIntel, Intel(R) Core(TM) i7-4578U CPU@3.00GHz
Graphics card: Intel Corporation Haswell-ULT integrated graphics controller (rev 09)
Motherboard: Apple Mac-35C5E0812OC7EEAF
I have QEMU 2.6.0, and Chameleon Enoch r2839 (I've also tried Chameleon 2.3 r2838 with the same results)

The command I use to boot is:

bin/qemu-system-x86_64 -enable-kvm -m 2048 \
      -cpu core2duo,vendor=GenuineIntel \
  -machine q35 \
  -usb -device usb-kbd -device usb-mouse \
  -device isa-applesmc,osk="insert-real-64-char-OSK-string-here" \
  -kernel ./chameleon_enoch\
  -smbios type=2 \
  -device ide-drive,bus=ide.2,drive=MacHDD \
  -drive id=MacHDD,if=none,file=./mac_hdd.img \
  -netdev user,id=hub0port0 \
  -device e1000-82545em,netdev=hub0port0,id=mac_vnet0 \
  -monitor stdio \
  -device ide-drive,bus=ide.0,drive=MacDVD \
  -drive id=MacDVD,if=none,snapshot=on,file=./Yosemite.10.10.2.iso

(real string osk string is inserted here, I just didn't add it for public posting)

When I boot, I get to this screen just fine:
original boot screen

When I boot with -v option, it gets to these screens, goes black, and then returns to the original boot screen shown previously: attempt1screen1

attempt1screen2 There does not appear to be any obvious errors or kernel panics. I googled the DSDT and SMBios messages and they don't appear to be anything that would cause issues in this case.

If I try booting it in safe mode (-v -x), I get these screens before it once again returns to the original boot screen:
attempt2screen1 attempt2screen2
Again, no obvious crashes or panics.

I've tried various combinations of -v, -f, -x, GraphicsEnabler=Yes/No, the behavior is basically always the same. Keep in mind, I am trying to boot and install OS X in a virtual machine, not on the computer itself.

Can anyone see any problems or suggest other troubleshooting I could do?

  • The SLA for OS X Yosemite does allow for its virtualization only on Apple-branded hardware however another requirement is it also has to be virtualized under a running occurrence of OS X not another OS on Apple-branded hardware. – user3439894 Jul 14 '16 at 17:31
  • Hmm, ok, I didn't realize it had to be also be running the software. That said, it's possible my company has a different SLA as this is for commercial use. I will have to ask further about my personal situation, but my question still stands. – Testing Jul 14 '16 at 19:07
  • @user3439894 I can't find the obligation to not run a virtualized OS X under a non-OS X operating system in the EULA. Where did you find it? – klanomath Jul 29 '16 at 0:57
  • @klanomath, In the SLA OSX1011.pdf Section 2, B, i & iii are the key parts. – user3439894 Jul 29 '16 at 1:33
  • @user3439894 2,B,i (only Apple hardware) is obvious, but in my opinion 2,B,iii allows to run e.g a virtualized OS X under Windows & VMware in a Boot Camp partition on Apple hardware. The german part (2,B,iii page 25 of 397) of the SLA doesn't even mention that OS X has to be installed on the Apple hardware and would allow KVM & a virtualized OS X. – klanomath Jul 29 '16 at 1:48

I eventually solved this: I had to upgrade from Ubuntu 14.04 to 16.04 and use just the GraphicsEnabler=No flag as a boot option. You enter it in the same place after boot: that the -v flag in the first screenshot.

Disclaimer: As far as the legal issues brought up in the comments, most people I talked to did not think you had to actively be running OS X on the machine, as you are allowed do things like run a different version of OS X in a VM, or use VMWare ESXi. I am not a lawyer and did not talk to one, so any individual concerned would have to consult their own legal team.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .