1

In the past, when I connected my mobile, Image Capture launched. I have an Android device.

At some point, I disabled this feature and now I need to set it back.

Unfortunately, I am not able to find how to do it.

I am on El Capitan 10.11.5

I have checked Photos but couldn't see any settings to change the default app.

So, what happens now is that I connect the device, I launch ImageCapture and it doesn't recognise the mobile.

Does anyone know how to fix this?

1

Per this answer, the setting is in Image Capture itself. Note, however, that the option won't show up in the bottom left corner until you actually connect your phone.

enter image description here

  • Sorry I should clarify. Now Image Capture doesn't recognise the mobile so, as you mention, I can't see this option. – John Kouraklis Jul 14 '16 at 10:54
  • @JohnKouraklis Try opening the Image Capture manually after connecting the device. – Shineeth Hamza Jul 14 '16 at 10:59
  • @ShineethHamza That's what I do. It doesn't recognise the device. I am very annoyed with Apple. They have messed up all their software – John Kouraklis Jul 14 '16 at 11:02
  • @JohnKouraklis Is iTunes detecting your device? else it will be a problem with your cable. – Shineeth Hamza Jul 14 '16 at 11:06
  • @ShineethHamza I have an android device. Should itunes detect it? – John Kouraklis Jul 14 '16 at 16:03
0

If you set a system setting to disable all hot-plug events, you might need to remove those settings specifically or generally:

defaults -currentHost write com.apple.ImageCapture disableHotPlug -bool NO

or to just clear that key in the preferences

defaults -currentHost delete com.apple.ImageCapture disableHotPlug

At that point, you should be able to go into Image Capture with the device connected and toggle the settings. I wonder if you have a connection issue if you don't see the device in ImageCapture - it should show up there once you have trusted the computer from the iOS device. I suppose that missing trust could also be the root cause.

To troubleshoot that, iTunes is a better option. Start here and if you can't see the device, there is a follow on article covering the ways to regain connection:

  • This must be the right approach but after searching my system I don't have such file which means that terminal can't alter the property. I get this error message: 2016-07-14 17:06:32.727 defaults[56553:4582570] Domain (com.apple.ImageCapture) not found. Defaults have not been changed. – John Kouraklis Jul 14 '16 at 16:09
  • @JohnKouraklis that's a good error - deleting something that's not there means you don't have that suppressing the pop up. It's then either lack of trust from iOS or a failure to communicate. – bmike Jul 16 '16 at 3:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .