I have a Macbook Pro Retina 13" (Early 2015) model and I have a bootcamp partition with Windows 8.1 Pro installed in it. The dual boot to OSX El Capitan and Windows was working just fine until about a month ago. I was switching operating systems using the option key at bootup through the Bootup drive selection screen and it was all working fine.

The problem I am facing right now is that every time I turn my laptop on or try to switch Operating systems using the option key the drive selection screen takes a long time to appear, like literally 20 to 30 seconds. This is not really normal because it used to be much faster. Also, once it appears with the Macintosh HD, Windows, and Recovery drives the mouse pointer just doesn't work or sometimes work un-reliably or extremely slowly. I have tried wireless and wired mouse in the screen and the results are similar. I can use the arrow keys in the keyboard to select the drives but the response is just too slow. Once i hit an arrow key it takes 15 to 20 seconds to register and move the selection, sometimes it doesn't respond at all. And then finally when I hit return it takes another half a minute or so to load up the boot sequence (Apple logo for OSX and spinning circle for Windows).

I ran diskutil to verify the volumes but everything seems fine. The disk health shows fine and I also ran First Aid on the Macintosh HD as well, but to no avail. I then tried by resetting the SMC and NVRAM but the problem still persisted. I updated bootcamp drivers as well as Windows updates, but the situation stayed. Finally, I took the laptop to an Apple store and the technician saw the issue, never ran any diagnostic and simply said something like "looks like an issue with EFI, we will have to send it for repair to change the logic board because the memory is soldered into the logic board", I couldn't fully understand what he meant by that and I am skeptical if it is really a hardware issue because the operating systems (OSX and Windows) both run just fine once it boots up.

A few odd behaviours I noticed-

  1. When restarting from Windows to OSX the boot drive selection screen sometime works normal. Fast and as if nothing really happened.
  2. When booting up the machine from a powered down state into OSX (without using option key, since Macintosh HD is my primary boot drive) the boot sequence (Apple logo with the loading bar) takes a while to appear.
  3. This issue probably didn't happen until I upgraded to OSX 10.11.5 from 10.11.4/3.

Points worth mentioning:

I use Tuxera NTFS and I know that there is a known NTFS driver compatibility issue between OSX default NTFS driver and Tuxera's NTFS version. Thinking this could be the problem I tried to repeat all the remediation steps by completely disabling Tuxera, but the problem still persisted. I feel that Tuxera may not be an issue because I have been using both Bootcamp Windows and Tuxera for quite a while and never faced any issues. I am considering a clean install of bootcamp with Win 8.1 Pro, if I absolutely have to, but would like to avoid because it's my work setup and I will have to set everything up from scratch.

I have already searched may online articles and community posts but haven't been able to find anything similar to this situation. So my ask is that, could it really be a Hardware (RAM) related issue as the Genius bar tells me? or is there anything known that I may try (and that I haven't already tried as stated above) to see if it resolves the issue?

Added More info from system log-

I ran sudo dmesg | more through terminal to view the last startup log immediately after a bootup and it seems in the beginning there are a bunch of kext related errors. I haven't done much research on the error but seems like a kernel panic of some sort, I just can't ascertain if this is being caused by a software or is it a hardware issue.

Kext com.apple.driver.AppleIntelLpssUARTCommon start failed (result 0xdc00400a).
Kext com.apple.driver.AppleIntelLpssUARTCommon failed to load (0xdc008017).
Dependency com.apple.driver.AppleIntelLpssUARTCommon of kext com.apple.driver.AppleIntelLpssUARTv0 failed to load.
Can't remove kext com.apple.driver.AppleIntelLpssUARTCommon; services failed to terminate - 0xdc008018.
Kext com.apple.driver.AppleIntelLpssUARTv0 failed to load (0xdc008015).
Failed to load kext com.apple.driver.AppleIntelLpssUARTv0 (error 0xdc008015).
AppleCamIn::probe
fUseGPUBusy = 0 fPPPMSupport = 1
**** [IOBluetoothHostControllerUSBTransport][start] -- completed -- result = TRUE -- 0x2800 ****
**** [BroadcomBluetoothHostControllerUSBTransport][start] -- Completed (matched on Interface) -- 0x2800 ****
Couldn't alloc class "AppleIntelLpssUARTv0"
AppleCamIn::start

Ran diskutil verifyvolume on my EFI volume and it came back with some errors-

Verifying file system
** /dev/rdisk0s1
** Phase 1 - Preparing FAT
** Phase 2 - Checking Directories
/EFI/APPLE/EXTENSIONS/Firmware.scap starts with free cluster
Truncate? no
/EFI/APPLE/EXTENSIONS/Firmware.scap: Cluster chain starting at 6 ends with cluster marked free
Truncate? no
size of /EFI/APPLE/EXTENSIONS/Firmware.scap is 15729264, should at most be 512
Truncate? no
** Phase 3 - Checking for Orphan Clusters
Found orphan cluster(s)
Fix? no
Found 30600 orphaned clusters
Free space in FSInfo block (303079) not correct (303078)
Fix? no
179 files, 151539 KiB free (303078 clusters)
File system check exit code is 8
Error: -69845: File system verify or repair failed
Underlying error: 8: POSIX reports: Exec format error
  • Have you tried running the Disk Utility on the hidden EFI partition? Also, have you run CHKDSK on the Windows volume? – David Anderson Aug 1 '16 at 15:52
  • I have run CHKDSK on the Windows parition, but it didn't show up with anything wrong. I haven't tried running Disk Utility on the hidden EFI partition but I will try that today. – Annjawn Aug 1 '16 at 23:43
  • @DavidAnderson quick question - will this method diskutil verifyDisk disk0s1 work to verify the EFI partition (disk0s1 identifier). Or do I need to mount it first? I know that mounting it could be a lengthy process. – Annjawn Aug 2 '16 at 4:48
  • 1
    You are close. The command is diskutil verifyvolume disk0s1. Just so you know, if you wanted to mount this volume, the command would be diskutil mount disk0s1. To unmount, the command is diskutil unmount disk0s1. To repair, the command is diskutil repairvolume disk0s1. Mounting is not required to verify or repair the volume. – David Anderson Aug 2 '16 at 13:02
  • Thanks. I tried verifyDisk but it asked me to enter the whole disk, so i knew that something was wrong with the command. volume instead of Disk didn't cross my mind, guess I should've seen the man page. I will try this today and let you know how it goes. – Annjawn Aug 2 '16 at 19:31
up vote 1 down vote accepted

According to Apple, the EFI partition is not used to boot OS X. The interesting think about the damaged Firmware.scap file, is that evidently the file is copied from the /usr/standalone/i386 folder to the /volumes/efi/EFI/APPLE/EXTENSIONS folder at boot time. See web site: /Volumes/EFI - Firmware.scap & MBA41_0077_B12_LOCKED.scap. If this is true, then you should not have to worry about replacing the damaged Firmware.scap file.

I suppose the next step would be to try and fix the EFI partition. If you wish, you could first backup this partition to a file. The file would be an exact image of the entire partition. To backup the entire EFI partition to the file named efi.binary, use the OS X command below. The partition should not be mounted, before entering the command.

sudo dd if=/dev/disk0s1 of=efi.binary bs=409600

If something goes wrong, you can at least restore the EFI partition back to its original (faulty) condition. To restore the entire EFI partition from the file efi.binary, use the OS X command below. The partition should not be mounted, before entering the command.

sudo dd if=efi.binary of=/dev/disk0s1 bs=409600

The OS X command to repair the partition is given below.

diskutil repairvolume disk0s1

An alternative would be to use Windows to run chkdsk on the EFI partition. From a Administrator Command Prompt window, you could enter the following commands.

mountvol s: /s
chkdsk /f s:
mountvol s: /d

More information, about accessing the EFI partition from Windows, can be found at the web site: How do I mount the EFI partition on Windows 8.1 so that it is readable and writeable?

  • So I did all that was suggested by you but the problem still persisted. So yesterday I backed up OSX and Bootcamp partitions and pulled the trigger to re-install OSX from recovery. Once that completed the problem was gone entirely. I also realized something that even though I initially reported that external mouse and keyboards didn't work, i later found them to be working so i'm suspecting that the Startup manager was facing trouble loading the drivers and taking a lot of time. I will keep an eye on it and see if the problem comes back (hopefully it doesn't). – Annjawn Sep 19 '16 at 3:40
  • Annjawn, I ran into the exact same problem and I really don't want to reinstall everything from scratch. Have your problem ever came back after your reinstallation? – Anton Reshetnikov Oct 18 '16 at 17:01
  • 1
    @AntonReshetnikov I think there's atleast 2 more people in this page who have faced this issue and all of them including me have 1 thing in common- we use an SD card for additional storage. Turns out, it's a h/w issue (see the last answer by @sanarena) and s/w reinstall wouldn't like resolve anything (I have tried that). If it's bothering you a lot then I recommend taking it in for repair. For now, I have decided to just live with it. – Annjawn Mar 1 '17 at 6:08
  • Thanks. It looks like the I/O board is the problem. Here is my question about this issue: apple.stackexchange.com/questions/265980/… – Anton Reshetnikov Mar 2 '17 at 15:50

You could try setting up an external drive with the same setup as your current drive. Then try to boot from that drive. That will at least tell you if the problem resides in your hard drive or not.

Also have you looked around for people having problems with EFI on your model macbook, regardless if they have a partition setup like yours or not? If you can't find many people that have had problems, then I would be skeptical about the genius bar.

  • I haven't found a single post online where the problem matches with my problem. Also, the OSX bootup sequence is significantly slow and is not that snappy anymore. It take a while for the Mac to show that white apple logo screen during the bootup. Still, I can't wrap my head around this being an EFI problem or anything related to the memory. – Annjawn Jul 28 '16 at 7:28
  • How is the performance once you have OSX booted and running? Also, did you try the setting up an external drive with the same setup? – grath Jul 29 '16 at 14:47
  • The performance within OSX and Windows is fine. I don't face any issues. The only slowness is during the boot drive selection. I haven't been able to use an external drive as you suggested, I don't have another copy of Windows to test it. I can try cloning the bootcamp partition to an external drive and give it try, but not sure if that'll work. – Annjawn Jul 29 '16 at 14:53

Today I've received my Macbook Pro 13inch 2015 back from Warranty and they have replaced I/O Board. Issue has been fixed. I was experiencing exact same issue and now it is gone.

  • How long did it take for them to replace it? Were you using SD card at all? Right now I only have this laptop an rely on it heavily for work so I can't afford to ship it away for even 2 days. The problem is not bothering me too much right now perhaps because I have come to truce with it but it still is a problem. – Annjawn Feb 27 '17 at 22:12
  • Mine was start to happen once I insert SD Card (and continue to persist even If I remove SD Card), but it is a I/O board issue and can show with or without SD card. They fixed for me on second visit when I mentioned it is SD Card issue to them. It took them one week. I also used my laptop for a while and suffering with this issue and gave my laptop to them when I was going for a short vacation, so it was fixed by time I come back. I use SD Card for extra storage and it is always inside my laptop – sanarena Mar 1 '17 at 5:37
  • Interesting, I have the same setup as you i.e. I have a Transcend JetDrive SD card always plugged in for more storage. There's another user above who also have the same setup as ours and facing the exact same issue. So I think it's safe to say that it's indeed a h/w issue just not what Apple Store told me when I took it there. I wonder if the issue would show up eventually again after a h/w replacement coz that would be bad. Are you planning on continuing using the SD card? – Annjawn Mar 1 '17 at 6:03
  • I am using it with SD Card 1st day I received it back, so far no problem. – sanarena Mar 2 '17 at 7:39

protected by Community Sep 20 '16 at 16:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.