3

My camera is currently set to take pictures in RAW + JPEG. I import the two files into the Photos app, and it combines them into one. I like this.

However, I have now used ExifTool to add in the GPS coordinates. I deleted the old files and re-imported them with the exact same file names. Now I have two pictures when I was expecting one.

If I take the original files and re-import them, they get combined again.

Is there some way to get Photos.app to realize that the two files should be combined?

3

I recently looked at a set of JPEG + RAW pairs that Apple Photos failed to match up. The behavior I observed was:

The images were geotagged and had GPS timestamp: GMT time of the GPS fix used to tag the images.

On the JPEG, Photos looked at the photo time and GPS time and figured that the clock time was 1 hour apart. It concluded that the camera clock was set to GMT+1.

On the RAW, it seems that Photos ignored the GPS time. Instead it worked from my computer clock. This is at GMT+2. It loaded the RAW assuming that the camera clock was set to GMT+2.

In the Photos application, both JPEG and RAW were displayed with the same clock time: the one recorded by the camera. In the library however the images were stored with timestamps 1 hour apart. The only way to “see” this in the Photos application was to sort the images by date. Pairs were not be sorted next to each other.

One fix is to use ExifTool or HoudahGeo to write timestamps including time zone offsets to both JPEG and RAW files. Once the timestamps on the JPEG and RAW are an exact match, Photos should recognize the pair.

BTW: I do consider this to be a bug in Apple Photos. The assumption that camera and computer clock are set the same time zone is rather common, yet unfortunate. The fact that Photos makes different assumptions on the JPEG and the RAW surely is a bug.

Full disclosure: I am the developer behind HoudahGeo.

  • Thanks, your software has been very handy to me in the past year or so. You should add to your answer that you need to check the "Timestamp" checkbox when exporting as it is not selected by default. – Andy Ibanez Mar 7 '17 at 0:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .