My Macbook runs El Capitan, 11.5. This morning, it failed to connect to my home network - which has been working for years. I'm now getting the

Cannot join wifi network X “please move closer”

message. My other devices still connect. I have tried from this question to connect manually and it chucks the following error:

com.apple.wifi.apple80211API.error error -3905

I have also:

  • deleted my network preferences etc
  • reset PRAM
  • reset SMC
  • changed modem channel

Tethering to my phone still works, but that's not through WIFI. Any suggestions?

  • Have you rebooted the router, (and wifi radio, if a separate device)?
    – IconDaemon
    Jul 14, 2016 at 1:17

3 Answers 3


I can't comment, as I don't have the rep - but have you checked /var/log/wifi.log when you've tried to connect? It might offer some other clues.

You seem quite comfortable with Terminal, so make it full screen and type networksetup and have a look through the options of that command. There are quite of lot (of options) and examples.

Have you also tried rebooting your home router?

  • @Jorg, how exactly did you solved your problem? It's not obvious what part of this answer helped you.
    – kelin
    Jun 10, 2020 at 8:39

You can change the channel of your router, maybe it is the problem with it. Another possibility is that a Firewall is preventing this. Go to System Prederences-Privacy and Security and then find the Firewall option. Check if it is turned on or off. Change it to either way and check if you can connect now. Additionally, you can go to Keychain Access app and try to remove everything related to the router such as its password or ... But be careful and don't remove important passwords. You can also use the built in diagnoser, which is in System Preferences- Network-Assist Me. See what it suggests. It usually says that you'd better turn your router off for a minute and turn it on again. You actually have to play (!) with three files in your System Configuration, which the link below explains how.

This discussion in Apple Discussions is also noteworthy : https://discussions.apple.com/thread/6354581?tstart=0

  • I tried the channel trick, but that was a no-go either. I'll try the firewall, but nothing's changed there. One moment it connects, the next moment I get errors.
    – Jorg
    Jul 13, 2016 at 23:56

If you already tried deleting your network preferences, i guess you went to to the System preferences -> Network -> Wifi -> Advanced -> Prefered networks and deleted the network in question. If not, try that first.

Then go to the System Keychain, Applications -> Utilities -> Keychain assistant -> System -> Search for your network and delete the password.

Try reconnecting to the network, hopefully that will work. Otherwise, restart router and computer ;)

I can't comment, as I don't have the rep.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .