3

When I go to shutdown my mid 2011 Mac Mini (running OS X El Cap, EDIT* 10.11.6), it will not do so "cleanly." I close all applications, then click Apple > Shutdown and finder closes like it's going to shutdown, but it gets stuck. I have to hold the power button till it shuts down, then when it powers back on I get the error message (with a yellow exclamation point):

You shut down your computer because of a problem. If you want to open the applications that were open when you shut down, click Open. If you do nothing, the computer will continue to login in 17 seconds...

So far I have tried:
- Opening Disk Utility and running "First Aid" on the SSD. I get a green check mark when done.
- Booting to Recovery (Cmd + R) and running First Aid.

EDIT: Apparently "First Aid" is not the same as repairing disk permissions! Looking into this... http://osxdaily.com/2015/11/04/verify-repair-permissions-mac-os-x/

EDIT2: As a result of the issue, I am unable to install any OS X updates and the only way I can reboot is via the terminal command sudo reboot now

EDIT3: Booting in verbose mode, I see many (about 20 or so) of these:
Could not open PlatformSupport.plist
and also...
ERROR!!! Recovery Image verification fail with status [0x800000000000000e] Error loading kernel cache 0oxe)

What could be the issue here? Anyone know what logs files I can check and where? Thanks.

  • Any messages in the system.log happening before you force shutdown to provide a clue? – user3439894 Jul 13 '16 at 17:59
  • Thank you. I've found the system.log in \private\var\log but is VERY verbose and hard to wade through. Any ideas what I'm looking for, what word, phrase, codes, etc?? – SamAndrew81 Jul 13 '16 at 23:37
  • I ran a permissions repair and the problem seems to have stopped....for now. – SamAndrew81 Jul 18 '16 at 18:47
  • 2
    One of the things that I do to attempt to diagnose this is to boot from a clean (meaning not upgraded) install. You can do this with an external USB disk/flash as it's only for diagnostics. If you can boot up and shut down cleanly, you have effectively eliminated all hardware with the exception of your drive, and narrowed it down to an install issue. Give that a shot and report back with your results. – Allan Jul 11 '17 at 14:02
  • 1
    Boot in single user mode - Command-S at startup. Once fully booted (it will take longer than usual) restart. This may clear out some wonky cache files causing a problem. Create or use another user account, logout of the account causing the null shutdown (if you can) and try restarting/shutting down from that account. If it works, then it is some glitch in your user account. I had this exact problem and I traced it to the behind-the-scenes Google Updater software any Google app installs. If you have ever installed any Google app, even if you never use it, this crap runs in the background. – IconDaemon Jul 13 '17 at 17:01
5
+75

Firstly, you should update to OS X 10.11.6. It will solve many problems. Download 10.11.6 Update.

Secondly, reset SMC. Here is a link how to do it: Resetting System Management Controller.

If it doesn't help, try clean install: How to Clean Install El Capitan.

ADDITION:

If you can't do clean install using your own mac, make a bootable USB on another mac: Click here.

Also, go to Utilities and run Console.app for inspecting what's wrong with your OS: Click here.

It might be a problem with a hardware, so try single-user mode pressing cmd-s after startup 'chime' sound or verbose mode pressing cmd-v the same way. To read about it Click here.

And read an important post about 7 Mac Startup Options: Click here.

  • Thank you, Andy! When I got this Mac (last Summer) I did do a clean install, so I'm not ready to go to those lengths just yet. I will try your other suggestions and report back... – SamAndrew81 Jul 11 '17 at 14:16
  • So a "SMC reset" is just unplugging power from the Mac Mini for 15 seconds or more, which I have done several times since this issue started...it does nothing. I cannot update OS X because the pending update requires a "clean" restart, which I cannot do due to the issue itself. – SamAndrew81 Jul 13 '17 at 4:11
  • ...the Mac Mini is already on 10.11.6, it's just a "Mac App Store Update for OS X El Capitan" and an OS X "Security Update 2017-002 10.11-6" that are pending the updates in App Store. – SamAndrew81 Jul 13 '17 at 4:14
  • 1
    And about "Could not open PlatformSupport.plist" discussions.apple.com/thread/7148558?start=0&tstart=0 – user243793 Jul 13 '17 at 18:01
  • 1
    I think this is an issue with my OWC SSD (and/or the firmware on the SSD) BUT I have not had time to verify this, unfortunately. Thanks for all the help everyone. I at least have a handle on the issue now. – SamAndrew81 Jul 19 '17 at 15:03
3

Try to

  • Boot into verbose mode (hold option-V during boot), and then try to shutdown. Does the log appear?

  • After you option-clicked on Apple->Shutdown, wait for two minutes. Does a windows saying "Application xyz prevented shutdown appear?"

  • Please check any non-apple extensions by running

    kextstat -l | grep --invert-match com.apple

    in the Terminal


Thanks for the feedback. When you boot into verbose mode, you automatically shutdown in verbose mode too; that was the main reason I suggested you do that so you see if it hangs "during" shutdown.

"Normal" applications that do not close upon request will get you a "Application xyz prevented shutdown" window. So since you do not have that, it's very likely to be a driver issue. I would suggest you manually kextunload (just search stackoverflow on how to do that) these extensions before you shutdown just to test if that fixes the problem. I'll think again if I come up with an idea what might be the issue here.

(s.th. like this, but you may have to check if there are dependent kext's you have to unload first)

sudo kextunload -b com.github.osxfuse.filesystems.osxfusefs

Be aware that an application-level firewall might block a network request of a (system) application that is executes when it is asked to terminate for shutdown. This might cause the behaviour you experience. You should definitely try just to turn off the firewall and see if the shutdown then works properly. This is a rather likely cause, i had something similar with little snich some time ago.

Once you have triggered shutdown, you can also manually kill processes that you think might be hindering the shutdown process to find the root cause.

Go "ps -A" and then "sudo kill -9 ####" with ### being the process number to terminate. Since the "force shutdown" from the command line works, this will likely lead to a shutdown, too.

  • Thank you, @user2707001. I ran that terminal command and it returned: com.m-audio.driver.firewire (1.10.5) no UUID <82 81 55 5 4 3> 129 0 0xffffff7f82dd6000 0x2000 0x2000 com.radiosilenceapp.nke.filter (1) 99B5954F-1C5A-3ABC-A445-899F21E1A19A <4 1> – SamAndrew81 Jul 13 '17 at 4:06
  • RadioSilence is a software firewall which I can get rid of, but the M-Audio driver is for my audio interface, so I cannot get rid of it. I did have to disable the "CSR Util" (System Integrity Protection) for that driver to work...could that be the root of the issue you think?? – SamAndrew81 Jul 13 '17 at 4:08
  • RE: "After you option-clicked on Apple->Shutdown, wait for two minutes. Does a windows saying "Application xyz prevented shutdown appear?" No, nothing ever comes up, OS X just never shuts down. – SamAndrew81 Jul 13 '17 at 4:23
  • 1
    Thanks for your feedback. I'm a bit busy atm but tried to give you a hint on how to find the root cause. – user2707001 Jul 13 '17 at 22:54
0

This was an OS software issue after all. Once I updated the Mac Mini to macOS High Sierra it was able to install updates and reboot again normally.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .