I do not use Mail.app, instead using Postbox 2 for all my email needs. I do use iCal for my calendaring, syncing it with my Google Apps accounts.

Whenever iCal wants to send a reminder, it tries to open Mail.app to do so, which is highly annoying.

Currently the only solution I have working is to zip up Mail.app in /Applications so iCal can no longer access it. However whenever the OS updates (i.e. from Snow Leopard to Lion) it replaces Mail.app and I have to do this again. This seems overly hackish.

Is there a way to force iCal to stop trying to open Mail.app without having to manually remove Mail.app?

  • Has anyone figured this out? I am currently using Postbox 2 and modified the applescript file inside the mail app and iCal still opens Mail when a reminder triggers. I've also changed the default app setting in the Mail App to be PostBox but no go. I asked PostBox support team to help me figure this out but apparently they can't so instead they offered me a refund. But I don't want a refund, I just want this to work :( Thanks!
    – user14267
    Commented Nov 28, 2011 at 21:40
  • @Xavier I never did find a suitable work around. Commented Nov 29, 2011 at 18:29

5 Answers 5


The instructions below (posted here) did it for us as our permissions were, actually, on "Read Only" and the Mail.app was still launching.

Note: If iCal still opens Mail.app for mailing an event after you have set Postbox as your default mail client:

  1. Within the Finder, right-click on the iCal icon and then select Show Package Contents.
  2. Navigate to the "Contents" folder, then the "Resources" folder. Right-click on the folder called "Scripts" and select Get Info.
  3. Expand the Sharing & Permissions box and click the Lock Icon in the lower right hand corner to unlock this setting. Change any permissions that are listed as "Read Only" to "Read & Write."
  4. Restart Postbox.

If more information is needed, check out a more detailed Postbox iCal Integration page for more options and troubleshooting tips.

Have a great day!

  • I followed the instructions in the second link and I can see that Postbox has modified the mail script now. Will let you know if this works and will mark as answered if it does. Commented Jan 3, 2012 at 12:43
  • Actually this didn't work. Mail.app is still opened by iCal to send notifications. Commented Jan 4, 2012 at 14:20
  • Have you heard anything, Darren? I'd be curious if the guys at Postbox have further info. I'll send a whatever they write back to me if I find it useful for us here!
    – Caleb
    Commented Jan 7, 2012 at 12:31
  • Havent heard anything. The script works, but iCal still wants to open Mail.app when its time to send a notification, which means I have to go back to deleting Mail.app alltogether. Commented Jan 8, 2012 at 16:01

The non useful way is not to set email as the reminder action in iCal.

More constructively is to write an Automator action that uses Postbox and then use that automator action as the reminder action.

I have an automator as an app and this is entered in the iCal GetInfo as


To create an iCal Alarm - Start automator and the first thing offers options for the workflow and one of them is an iCal Alarm - The automator then can include a shell or applescript script to call your mailer


I had the same thing and found the answer on SuperUser:

Therefore, unless you disable Mail.app responding to this AppleScript call (tell application "Mail"), there's really only one way to kill Mail.app (as per my comment on waiwai's answer):

sudo chmod 000 /Applications/Mail.app/Contents/MacOS/Mail

To reverse:

sudo chmod 755 /Applications/Mail.app/Contents/MacOS/Mail

You can try this :

Open the Mail App. Then, in the Preferences Dialogue Box, change the value of the pop-up menu parameter called "Default email reader" to "Postbox 2".

enter image description here

  • 2
    This doesn't seem to work. I have Default email reader: in Mail.app on my system set to Sparrow.app (1.3.2) and iCal still tries to open Mail.app to send changes to events to other attendees and notifications for events.
    – Ian C.
    Commented Sep 9, 2011 at 15:06
  • I've done this as well, and it doesn't work. Commented Sep 9, 2011 at 15:19
  • This doesn't work. iCal opens Mail.app from an Apple Script file. It does not respect this setting. If you use Sparrow you can try to use my script: gidogeek.com/post/6037637963/ical-sparrow it doesn't work for 10.8 however.
    – Gidogeek
    Commented Apr 19, 2013 at 18:58

A similar question was recently asked about Sparrow here: How can I use Sparrow to send iCal e-mail notifications instead of Mail.app?

In answer to that question I found a script that does close to what you want but for Sparrow (an alternate mail client for OS X). You might be able to alter that AppleScript to achieve what you are after with your mail client of choice.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .