0

I have just purchased an 2.5" external hard drive enclosure to accommodate my 2.5" SATA hard disk for use on my El Capitan 10.11.5 MacBook Pro Retina 15 (A1398) computer.

However, every time connect the USB external hard drive (in it's enclosure) the operating system is giving me this message, "The disk you inserted was not readable by this computer." with the options "Initialize... Ignore... Eject..".

I understand that the hard drive needs to be formatted, which I already have in various filesystems, for example: exFAT, OS X Extended (Journaled). I have also changed various schemes and partition tables in Disk Utility.

After the format, it appears as a working hard drive where I am able to copy items onto, fully functional. However, when I disconnect the hard drive I get the same message "The disk you inserted was not readable by this computer."

I have tried this on Windows alternative also. Do you think it could be a defective enclosure? Or is there something that I need to do?

I have also used DiskWarrior 5.0 to repair filesystems etc.

Any advice would be great.

  • It sounds like the enclosure is at fault. Return it and get a replacement, and if that one doesn't work, seek out a new manufacturer. – IconDaemon Jul 12 '16 at 12:05
1

If OS X cannot erase and partition a new drive, then either you have a rare corrupt data or hardware problem. Have you tried booting to recovery HD and using disk utility to repartition the drive entirely.

Choose APM to make sure you can write a new partition map. Then repartition to how you want to use the drive. If that fails, seek hardware repair or start to isolate the cable or enclosure or drive as the thing that fails.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .