I recently switched to zsh from bash, and Go2Shell doesn't work with zsh. When I click the Go2Shell icon from Finder, the iTerm window opened but the directory is the last dir in iTerm instead of the current dir in Finder.

How can I achieve the old function or is there a replacement of Go2Shell?

  • My experience is that Go2Shell doesn't work well with the latest iTerm at all, I guess the shell shouldn't matter. For me, if iTerm is already open, clicking the Go2Shell button works opening a new tab, but if the app is closed it drops me in the previously used directory, not the Finder directory. Do you see the same when you've set Go2Shell to New Tab instead of new window?
    – oarfish
    Jul 12, 2016 at 9:15
  • @oarfish It will open the same directory as the right most tab, and home directory if iTerm is not open. Same result if I chose open with new window.
    – leetom
    Jul 12, 2016 at 13:22
  • Sounds like it's just the same bug I face. You can mail zipzapmac, maybe they'll do something about it. But I reported it like a year ago and while they did say they looked into it, nothing happened after that. That's what you get for it being free I guess.
    – oarfish
    Jul 12, 2016 at 13:24

1 Answer 1


I solved same issue with Turn on System Preferences -> Security & Privacy -> Automation -> Go2Shell.app with Finder, iTerm.app or Terminal

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .