9

In my Chrome Browser, whenever i "Force Click" (hard clicked by one finger) upon a Word, the dictionary lookup Pop-up is always popping out.

Like this:

enter image description here

I have already DISABLED the "Force Click" setting in the Trackpad Settings:

enter image description here

And then already Restarted the Chrome. And also did (related or not) the:

$ killall SystemUIServer

But this annoying pop-up (Dictionary Lookup) is still there. I'm sure it is not a Chrome Extension.

What should i do to totally get rid of that, please?

Thank you all!

  • For clarity, "Look up & data detectors" and the killall SystemUIServer is unnecessary/irrelevant - just uncheck "Force Click and haptic feedback" (see @Scott answer below) – Geoffrey Hale Sep 4 '18 at 23:01
8

Switch 'Look up & Data Detectors' to 3-finger tap. You can then re-enable it. This avoids disabling force touch entirely.

  • what about iMac? – Sayan May 3 at 17:08
7

You have to also uncheck "Force Click and haptic feedback" at the bottom of the Trackpad Point & Click settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .