1

I just received a new MacBook, running OS X El Capitan 10.11.5, from my new employer and I am unable to force hidden files to show in Finder. This is my fourth MacBook, and in the past I have always used defaults write com.apple.finder AppleShowAllFiles YES to show hidden files; however, on my new Mac, this is not showing the hidden files. I also tried defaults write com.apple.finder AppleShowAllFiles TRUE but still cannot see hidden files in Terminal or in Finder. I restarted my computer, but that didn't solve my issue either. Any ideas on how to show my Mac's hidden files?

2

After you run the defaults write com.apple.finder AppleShowAllFiles YES command, hold the 'option/alt' key, then right click on the Finder icon in the dock and click Relaunch.

1

Try this:

defaults write com.apple.Finder AppleShowAllFiles -bool true; killall Finder

This sets AppleShowAllFiles to true which tells Finder to show all file. Note the -bool part, that tells will make sure you are setting a Boolean to it instead of string, integer etc. Finally it restarts Finder.

  • Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions – Allan Jul 11 '16 at 1:45
  • @Allan Edited with explanation. – Tom Shen Jul 11 '16 at 1:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .