Newly upgraded to Latest released OS X - El Capitan (10.11.5). Now when I open App Store app, the spinning wheel to right of < > buttons on upper left side continues to spin with no content visible below on any tab button. Originally, I saw that 1-update was available. I read an earlier note to use Activity Monitor and kill processes related to App Store. Saw 2 that had long process times (storeassetd, storedownloadd). Plus now see App Store Web Content in "(not responding state). How do I fix this???

4 Answers 4

  • Go to Finder and press + Shift + G;
  • Locate ~/Library/Caches/com.apple.appstore and delete com.apple.appstore which are cache files;
  • Then press again those commands and go /private/var/folders, open each folder and each subfolder until you find com.apple.appstore and delete this folder;
  • Restart your Mac.
  • 1
    No such ~/Library/Caches/com.apple.appstore directory exists. Nor does (terminal) /private/var/folders/ contain anything related to "com.apple.appstore". Will restart in a few minutes. Maybe this will correct things. Jul 10, 2016 at 17:04
  • 1
    Did all this. Doesn't seem to make a diff. No tab displays any content. Yet I was told a update was available. I selected Install. It went of to do something. Don't know what. Jul 10, 2016 at 21:03
  • 1
    Strange, they exist on my Mac. Ah, go only to ~/Library/Caches/ and find folders the com.apple.appstore, storeaccount, storeassets, storedownload and storeinapp. Delete these folders. Then go again to /private/var/folders/. At /private/var/folders/, there are two subfolders, go to the first subfolder and then go to that folder and after to the folder C that cointains the folder com.apple.appstore. Jul 11, 2016 at 1:38
  • 2
    I contacted Apple. They told me to delete the whole Caches folder at the location you mentioned. Cause a bunch of problems that just got resolved and a lot of time and a couple reboots. Its working now. Maybe I'll follow your suggestions to the letter from now on. Jul 12, 2016 at 22:12
  • 6
    Combined all these and it finally seemed to do the trick. sudo find /private/var/folders/ -iname 'com.apple.appstore' 2>/dev/null | while IFS='' read -r line; do rm -fr "$line"; done; rm -fr ~/Library/Caches/*store*; ps aux | egrep -i 'app.?store' | awk '{ print $2 }' | while IFS='' read -r line; do kill -9 "$line"; done Stupid, stupid, stupid-stupid-stupid software. Oct 7, 2019 at 14:29

For me, the command that resolved this was:

sudo softwareupdate --clear-catalog

(Found here: https://apple.stackexchange.com/a/221419/238906)

  • 1
    Bear in mind, is for resetting the System Updates url for macOS. The OP is asking about App Store. Two different things.
    – Danny A
    Nov 18, 2019 at 15:43
  • 6
    This option is deprecated in Catalina (10.15.4, 19E287).
    – ives
    Apr 26, 2020 at 20:06

After hours of trying different ways of re-installing an app from the App Store (deleting the app in Launchpad, enabling app store debug menu and resetting application, rebooting, etc) the only thing that worked for me was deleting the following folders and rebooting:


After this I was finally able to see an "Install" button next to the app I deleted rather than an "Open" button. In addition, 5 other apps I had deleted were originally showing under the Updates tab as having updates. After deleting the above 4 folders, those apps were no longer showing up under the Updates tab.

I think it's absolutely ridiculous that there isn't an easier way to re-download/re-install an app from the App Store.


I have tried all of this. What I have done is delete the App Store key chain entry in Finder, Application, Utilities, Keychain Access and then search for appstore. Delete just that one. (MacOS Catalina).

  • Can you please provide more details on how to achieve this? None of the previously mentioned solutions work in Catalina. Thanks
    – Chris
    Dec 19, 2020 at 3:07
  • Hi Chris! I just done that. First go to Finder, then Application and so on as my answer described. Please, follow that and let me know.
    – Ignacio
    Dec 19, 2020 at 11:16
  • Hi, thanks, I am just not sure what exactly I should be deleting. Can you please be more specific in what files I need to delete, thanks!
    – Chris
    Dec 21, 2020 at 2:13
  • Chris, there you will find lot of entries, like a list of items. One of them may be called appstore or similar. Delete just that. I cannot be more specific because it is just that. Perhaps you don't have that item (or file). Hope you find it!
    – Ignacio
    Dec 21, 2020 at 11:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .