7

I have the following issues / question. I use WIFI and Ethernet through each other like most people probably.

Certain things like ripping a blu ray I want to do through the Ethernet connection so that is when I plug it on.

However, I first have to turn WIFI off to "force" the mac to choose to route the data through the Ethernet connection.

In system settings under network / priorities I have the proper order, so Thunderbolt Ethernet above WIFI.

Any idea how I can make the Mac use the Ethernet cable without turning off the WIFI? THANKS!

marked as duplicate by Allan, bmike macbook Jul 9 '16 at 16:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Why do you need both? Are you on seperate networks? Just out of curiosity, how do you "rip a blu ray through the Ethernet?" – Allan Jul 9 '16 at 15:42
  • When I rip a blu Ray I do this directly to my NAS. With a gigabit Ethernet connection this is much faster. That is what I meant. Cheers. – Arnoud Jul 9 '16 at 20:25
  • Alain, I now also read the other post. I think I have to rephrase. The question basically is that I have the correct priority settings. When I am on wifi and plug the Ethernet also on it is not used in the same (speedy) way as Ethernet alone. The speed difference is huge. What can cause this and what to do to solve other than my own workaround of simply turning off wifi? – Arnoud Jul 9 '16 at 20:37
  • I am still not clear on what you are trying to do. Is WiFi and Ethernet on the same network? If so, why? – Allan Jul 9 '16 at 20:39
  • Yes, on the same network. I would expect everybody to do this the same way not? You just walk around the house using wifi and when higher speed is needed you plug in the Ethernet. Why is the Mac not following the priority list as of that moment? – Arnoud Jul 10 '16 at 17:25
14

According to Apple Support:

  1. Choose Apple menu > System Preferences, then click Network.
  2. Click the Action pop-up menu , then choose Set Service Order.
  3. Drag a service, such as Ethernet, to the top of the list.
  4. Click OK, then click Apply to make the new settings active.

Full article is here.

  • 1
    As I mentioned in my post I already had this done so Ethernet is on top of wifi in the priority settings. However it feels a bit that if you start a connection or a share or so with wifi it will not use Ethernet when that is enabled after wifi. – Arnoud Jul 9 '16 at 20:27
  • @Arnoud Ah! My bad. – Munesawagi Jul 9 '16 at 20:34
  • This didnt work for me. Ethernet is still at the top of the list, (has been by default) yet it's using the wifi as the main source of internet. – timothymarois Dec 24 '18 at 14:55
  • 2
    Feb 2019 running macOS 10.14.3 and this still doesn't work. None of my Macs will prioritise ethernet unless I turn off wifi, and if I do that I lose the ability to unlock my Mac with my Apple Watch. – Dave Sag Feb 8 at 6:02

Not the answer you're looking for? Browse other questions tagged .