I have a MacBook Pro 2015 and I am dual booting with Linux. I use rEFInd and since day 1 it has been working fine on most occasions. Sometimes it would take a long time to show its screen and then it would freeze, updating every 5-10 seconds (so if I press down on my keyboard twice, it would jump two entries down in a few seconds). In those cases I would clear the PRAM/NVRAM, re-bless rEFInd and it will be ok. Recently however it happened again and this time resetting PRAM/NVRAM does not help. Furthermore, under Linux no input devices work (neither internal, nor USB keyboard). lshw lists them as working and with a loaded kernel module for them... Internal keyboard works under OS X.

EDIT: The reason I think it may be a hardware problem Related to the issue is that loading the bootloader (whether it is rEFInd after I bless it, or the native Apple bootloader as soon as I clear PRAM) takes about 20 seconds after the start up chime, which is not normal. I noticed that after I reset PRAM, I hear the start up chime, only 3 seconds later I see the Apple logo (boot is fast) and on the very next reboot, it hangs somewhere, which now leads me to believe that maybe some of my OS X settings which also modify the PRAM are corrupted and corrupt the PRAM. Is there a way to prevent OS X from modifying the PRAM in ANY way?

I'd hate to take it to a service, since they'll tell me "20 seconds is not long and we don't deal with 3rd party loaders", but I know it never used to take more than 3 seconds to show the Apple logo, so something must have changed. Ideas?

P.S. I use Gentoo, whose kernel is perfectly capable of being booted directly from the UEFI firmware and there are instructions on how to do this using efibootmgr but they are not specifically for Macs and I've read in some places that efibootmgr may/will brick the firmware on Macs so I am reluctant to try...

2 Answers 2


I'm assuming you're dealing with a Retina MacBook Pro. If your Mac is taking that long to find something to boot and then also taking forever to boot afterwards then you may potentially have faulty storage.

Yes they probably will baulk at the 3rd party boot loader but as long as you have a backup you'll be OK. The Apple Store will run hardware tests to confirm whether or not the storage is faulty as well as reload the current version of OS X after wiping your storage. It's part of their testing so if they can't load OS X cleanly then it's definitely a hardware issue.

You can find your local contact number here: https://support.apple.com/en-au/HT201232

On that note, why not just try cleanly installing OS X yourself after erasing your storage?

See http://osxdaily.com/2014/12/14/reinstall-os-x-mac-internet-recovery/

If you can do that successfully then you're just looking at an issue with rEFInd and/or your Linux partition (by the way why not just get Linux booting natively through EFI without the extra boot loader? http://heeris.id.au/2014/ubuntu-plus-mac-pure-efi-boot-short-version/)

  • Thanks for replying. Yes it is a Retina model. I still have OS X installed, I am not allowed to remove it or reinstall it since this is a company MacBook (they just allowed me to install Linux as a second OS. As for that article you posted, apart from the fact that it erases OS X which I can't do, it still installs GRUB, so how is this "native without a bootloader"? I edited my post with some new information (see EDIT and P.S.) Jul 10, 2016 at 22:51

Edit: sorry I just realized this is a 1 year old thead I was exactly in the same boat as you. All the symptoms matches. For me it got fixed by updating the mac firmware. I went into macos downloaded all the updates, rebooted back to macos to ensure all the updates are installed and then the problem got fixed. I got the idea from https://wiki.archlinux.org/index.php/Mac#Firmware_updates I don't know what the root cause was, but it got fixed after updating mac firmware. It has been working fine for 3 days, not sure if it got fixed permanently.

  • Well, it's a worth a shot! I'm still having the same issue even after Apple replaced the MacBook. I removed Linux, put a clean install of OS X, took it to the store, they stripped it down to bare bones, ran all possible diagnostics for 2 weeks, couldn't figure out what was wrong (they were puzzled). So they just gave me a new one which started doing the same thing shortly after I installed Gentoo on it. I think what damaged it was improper wake up after hibernation. It only needs to happen once, then the symptoms stay... Will try the updated firmware soon and post what happens. May 10, 2017 at 20:56
  • I also experimented with bootloader. Before updating the firmware, I also tried grub, systemd-boot and rEFInd. So it doesn't seem to be a problem with rEFInd bootloader. May 14, 2017 at 13:34
  • (Sry couldn't edit the above comment after 5 mins)I also experimented with bootloader. Before updating the firmware, I also tried grub, systemd-boot and rEFInd. So it doesn't seem to be a problem with rEFInd bootloader. After updating the firmware rEFInd worked perfectly. But even though nothing was wrong with rEFInd I switched to systemd-boot after 2 days as that was the recommended way in arch wiki. wiki.archlinux.org/index.php/… About a week now.. everything is working fine. May 14, 2017 at 13:40
  • Well, I finally tried updating OS X (to Sierra) and that seemed to fix it (hope it doesn't start acting weirdly again). I suspect what messed it up is either disabling input devices from within Linux (using xinput) and not re-enabling them before shutdown, or hibernating to RAM from within Linux (which doesn't work properly anyway). I just won't do any of those now that it's working. Jun 16, 2017 at 10:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .