I have some songs in iTunes on my Mac (under 'My Music'). However, when I go to 'My Music' in the iOS Music app I don't see them. I do see 'Songs of Innocence', which I don't see on iTunes on the Mac.

Both devices are logged in which the same Apple account and signed up for iCloud.

I expect the same songs to appear in each place, but instead they are totally different.

Is there some setting I need to change to fix this? Or am I completely misunderstanding?

Many thanks, Tom

1 Answer 1


If you want your music to be uploaded to iCloud, you must sign up for iTunes Match.

Make sure you're running the latest version of OS X and iOS. (El Capitan - iOS 9 are the stable releases right now, although you can get the public beta of macOS Sierra and iOS 10).

Then make sure the Apple ID you've entered in the Music App on iOS is the exact one on the Mac's iTunes. If it didn't work, make sure both devices have been connected to the internet since setting the Apple ID.

By the way, "Songs of Innocence" is an album by Irish rock band U2, which was a 'gift' from Apple to you. If you want it removed, see this.

Of course, connecting your iOS device to your Mac can help you sync them. This webpage has got a table which lets you know how to do deal with some of these similar problems.

  • 1
    Thanks. Very helpful. iTunes Match is not really worth it for me. The stuff I want to sync actually isn't even music; it's just a bunch of random audio files (lectures, white noise tracks etc). Only about 40 files, so the cost of iTunes Match is a tad expensive for that use case. I think I'll just have to sync over USB, although it seems a bit barbaric these days! Thanks again.
    – Tom Scrace
    Commented Jul 8, 2016 at 15:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .