I have an older MacBook Pro (Late 2011) which came with a built-in optical drive. I replaced the built-in SuperDrive with a second hard drive. However, the USB SuperDrive is not compatible with Macs that came with built-in optical drives.

I tried modifying the /Library/Preferences/SystemConfiguration/com.apple.Boot.plist file with the mbasd=1 flag as I would have in Yosemite/Mavericks. However, I was presented with an Operation not permitted message, even when I tried this as root. (As it turns out, this is because of the new System Integrity Protection introduced in El Capitan, which supersedes root)

Is it possible to get a USB SuperDrive working in El Capitan? If so what are the steps?

  • doesn't it 'just work'? we bought a USB SuperDrive and it works just fine whichever MacBook Pro we plug it in to.. Jul 7, 2016 at 8:44
  • @JBRWilkinson Hmm, it never worked for me; however, I have a Late 2011 MacBook Pro which came with a built-in optical drive... Until I replaced it with an SSD and needed an external one :P It seems USB SuperDrives are only compatible with Macs that did not come with a built in optical drive: support.apple.com/en-ca/HT202665 Jul 7, 2016 at 22:52

2 Answers 2


I discovered this is a fast and simple way to enable a USB SuperDrive on El Capitan:

  1. Click on the "" (Apple) menu, select "Restart...", and then hold "⌘" (Command) and "R" at the same time until the progress bar appears. [This will boot El Capitan in recovery mode, which may take a little longer than usual.]

  2. Once booted into the GUI, click on the "Options" menu, and select "Terminal".

  3. Type csrutil disable, and then press return. [This will temporarily disable System Integrity Protection, which is only possible in recovery mode. This will allow us to modify the restricted *.plist file.]

  4. Type plutil -convert xml1 /Volumes/Macintosh\ HD/Library/Preferences/SystemConfiguration/com.apple.Boot.plist, and then press return.

  5. Type vi /Volumes/Macintosh\ HD/Library/Preferences/SystemConfiguration/com.apple.Boot.plist, and then press return.

  6. Add the mbasd=1 flag to the "Kernel Flags" string, and save the file. It should look like the file below:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
    <key>Kernel Flags</key>
  1. Type csrutil enable, and then press return.

  2. Type shutdown -r now, and then press return.

Once the system has restarted, you should now be able to use your USB SuperDrive.

  • 1
    It was working until high Sierra update. I have followed all these steps again but ıt is not working anymore on high Sierra. any ideas??
    – onur
    Sep 28, 2017 at 3:51

This is by far the easiest way to do this, without having to play around with system permissions, recovery mode etc.

Simply use this Terminal command:

sudo nvram boot-args="mbasd=1"

It will ask you for your user password, and if you’re logged on as administrator, nothing else is required (keep in mind it won’t show anything as you type, just keep typing and hit return at the end).

Reboot and you’re done, your CD/DVD drive is recognized. This also works for those who took their internal drive out and connected it via USB enclosure.

  • 1
    Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions
    – Allan
    Jul 8, 2016 at 12:35
  • This answer sloved my problem in just 30 seconds!!! Thanks alot !
    – iericzhou
    Mar 4, 2018 at 6:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .