I'm a developer, and my primary language is French, so I use Mac OS X in French. However, I need on a regular basis to open an application in English to do support.

Right now I'm going to the International System Preferences and I put English above in the languages list, then I open the app I need to run in English. When I'm done, I switch it back to French.

This is an annoying process. Is there something else I can use, like a command-line program, to launch an application in a specific language?


There is a freeware, Language Switcher, to launch a single application with a different languages.

it's really simple and work amazingly.

  • 8
    Under the hood, it just launches the program with a -AppleLanguages (French) switch, which is what I really needed. Thank you! – zneak Aug 18 '10 at 21:21

You can change the language inside the preferences file of the application :

defaults write com.apple.TextEdit AppleLanguages '("en-US")'

Or just run once one application with another language :

/Applications/iCal.app/Contents/MacOS/iCal -AppleLanguages '(de)'

To determine the bundle identifier, run

mdls -name kMDItemCFBundleIdentifier /Applications/Mail.app

or directly in one command:

defaults write $(mdls -name kMDItemCFBundleIdentifier -raw /Applications/Mail.app) AppleLanguages '("en-UK")'

(via SuperUser)

  • Interesting. The direct "program-call"-approach works for Excel, but not for Numbers. With Numbers you have to change language in the preference file. (The first example above). – Erk Oct 15 '16 at 21:45
  • This preference does not work anymore on 10.11. Is there any alternatives? – Hamid Rohani Oct 19 '16 at 12:00
  • 1
    It just worked for me on 10.11, no problem here. – Ben-Uri May 3 '17 at 21:50
  • Worked for me on High Sierra (10.13) as well. – Yassine El Badaoui Jan 19 '18 at 9:10
  • Confirmed to work on the Mojave beta. Thank you. – doque Sep 3 '18 at 18:00

Go to the app, Press Command + I and if there are other languages they will show up in the info page. Just untick all except the language you want

  • 5
    This no longer work in Snow Leopard. – Loïc Wolff Aug 18 '10 at 21:59

In the Finder, get info on the application. There are languages here, and you can choose. Alas, this seems to have disappeared in Snow Leopard.

  • 5
    How does this differ from @Avi's answer made 3 years ago? – Mark Aug 25 '13 at 11:07

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.