0

Following the instructions at http://www.techrepublic.com/blog/apple-in-the-enterprise/handy-screen-locking-tips-for-mac/ I've set up a keyboard shortcut to lock my screen by hitting Cmd ⌘ Ctrl ⌃ L . It works when the active window is Finder, or Notes, or Thunderbird, or ... well, most stuff.

There are a few applications where it doesn't though, Terminal being the most annoying. Terminal seems to capture it and treat it as ... well, I'm not sure what. It's not treating it the same as Ctrl ⌃ L , or the same as Cmd ⌘ L .

It also happens in Chrome, although only on some pages - this 'ere page being one of them.

It worked just fine before I upgraded to El Capitan.

Any suggestions for how to fix this?

2

The trick, really, is to avoid common key-commands - which is why the article you refer to uses Ctrl ⌃ Opt ⌥ L , as no OS X command would normally use only Ctrl ⌃ & Opt ⌥ - they would always add Cmd ⌘ too, leaving you free to use Ctrl ⌃ Opt ⌥ for anything you like.

If you insist on using Cmd ⌘ Ctrl ⌃ L then you would have to add, for each application that already uses it, a new custom command so it will no longer trigger in preference to your own.

For example, for Terminal, where Cmd ⌘ Ctrl ⌃ L is Clear Screen

enter image description here

you would need to replace that in System Prefs > Keyboard > Shortcuts > App Shortcuts

enter image description here

and add a different, non-conflicting shortcut.

  • If I change it to Ctrl-Opt-L then it seems to work even less. It doesn't work in Terminal, or System Preferences, or Thunderbird, or Finder. – DrHyde Jul 8 '16 at 14:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .