1

The Hitachi 5K750-500 initially installed in the MacBook A1278 13", Mid-2012 failed. I bought a new hard drive (Seagate ST500LT012) but it was not detected by the Disk Utility.

I found that the hard drive is not spinning when installed in the MacBook. When I plug this same drive on a PC it works well and I can hear the disk rotation. I tried two other hard drives on the MacBook and I can hear the disk rotation.

Do you have an idea what's going on and what I can do?

Edit: I tried two more hard drives. Here's a summary:

  • Seagate ST500LT012 (SATA 3): Not even spinning a second.
  • Western Digital WD5000LPVX (SATA 3): Spinning for a minute then stops. Not detected in Disk Utility.
  • Seagate ST9750420AS (SATA 2): Spinning, detected.
  • Original Drive Hitachi 5K750-500 (SATA 2): Was working before being faulty.

Is this SATA 2 / SATA 3 related?

Edit 2 : Fixed by replacing the "always faulty on the Mid-2012 MacBook" SATA cable.

  • Try running Apple Hardware Test (AHT). Hold the D key while booting from a powered off state with the AC adapter connected. I am thinking you may have an issue with the SATA controller as SATA drives are backward compatible (SATA III drive will work with SATA II ctrl) – Allan Jul 6 '16 at 11:23
  • 1
    Hi ! Thank you for this answer. The Apple Hardware Test detects no error. Now even my SATA 2 drives are sometimes not detected. I think it's related to the ultra thin SATA cable. I'll try to replace it before going further. – Toz Jul 7 '16 at 11:59
  • "Always faulty on the Mid-2012 MacBook." Do you have a source for this? Cables of this type don't fail unless you remove/install them incorrectly when servicing a MacBook. – Allan Jul 14 '16 at 17:12
  • youtube.com/watch?v=Amg5w0rlwDo Not an official source, but you can ask Google and see by yourself or trust my experience. The cable is so thin and right angles folded ... not really suprising they fail that often. – Toz Jul 15 '16 at 19:14
  • I have never run into this issue, but if what this guy is saying is correct, he needs to sand down the area that is damaging the cable, not put tape over it as putting tape doesn't solve the problem that is causing the damage. – Allan Jul 15 '16 at 19:22
0

Surely not all those hard drives are faulty, so I'd look at the SATA controller or cable. Seems you may already have figured that out though.

  • The SATA cable was the problem. Those cables always fails on these Mid-2012 MacBooks, but this one was harder to diagnose because it was sometimes working with other drives. – Toz Jul 14 '16 at 17:07
  • @Toz, can you mark mine as best answer then? I need some points so that I can comment on answers. Thank you. – SamAndrew81 Oct 24 '16 at 15:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .