For the past 4-5 days, I've been unable to send or receive photos with iMessage.

If I send, it hangs for a couple of minutes and then returns a "failed to send" message.

When receiving, little "tap to download" boxes come through, but the download progress never moves beyond 0kb.

The messages are definitely going over iMessage and not MMS, as I have cellular data turned off to prevent international roaming charges, and I send from my iCloud email.

The usage page was showing 2GB of free space, so that shouldn't be an issue. Since the problem started, I've tried both following the instructions here as well as doing a factory reset and restoring from a backup. The problem still persists.

Does anyone have a similar experience or an idea as to how this can be fixed?

1 Answer 1


I had this same issue a few months ago and I resolved it by turning off iMessage in Settings - Messages and then turning it back on.

  • Or not... I can send, but still not receive.
    – redwall_hp
    Commented Jul 7, 2016 at 0:54
  • It appears to work if I send myself a photo. (The new conversation created shows it properly.) But when I receive a photo from someone else, the problem persists.
    – redwall_hp
    Commented Jul 7, 2016 at 1:07
  • I also tried deleting the conversation with my contact, but photos still don't come through.
    – redwall_hp
    Commented Jul 7, 2016 at 1:21
  • Maybe try signing out of iCloud all together on that device, then sign back in. Commented Jul 7, 2016 at 2:01
  • Are you on wifi?
    – samh
    Commented Jul 7, 2016 at 2:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .