7

When I type any word ending with an 'l' (ell, like "local") and then press the / key, the 'l' is replaced with another symbol and the slash, '/', is omitted. How can I deactivate that function?

enter image description here

  • This looks like a rendering bug rather than an actual issue. Does it actually affect the content of your command? – Luke Taylor Jul 5 '16 at 16:20
  • @LukeTaylor But he gets a "no such file" message, so it is affecting the content, the sequence l/ is being changed to a totally different character. – Tom Gewecke Jul 5 '16 at 18:03
  • Ah, ok. Maybe not then. – Luke Taylor Jul 5 '16 at 18:04
  • It seems this could be specific for your user account; could you try creating a new user to see if it happens there, too? If not, then I'd suggest having a closer look at your .bashrc and .bash_profile, maybe you're having problems with bash completion? Also: what keyboard layout are you using? – Asmus Jul 11 '16 at 20:40
4

This looks like the behavior of some very old Mac fonts (Palatino was one of them) where you could make the character l with stroke (used in Polish and elsewhere) by typing such a sequence. Try changing your font. If this is in fact the cause of the problem, you should get rid of the font that does this, which should not be on any modern mac.

0

Seeing that you use white on black, I take it you use the "Pro" profile (unless you duplicated it or created a fresh new one).

I would look into Terminal's preferences and check the used encoding and other options. If there are differences with, let's say the "Basic" profile, try to see if using that profile is behaving the same or behaves as you would expect. If it is as you expect it, see about changing your used profile more and more to the comparison.

0

I had this same problem because I had an old Monaco font in ~/Library/Fonts/. I was able to disable the old font with FontBook, and the issue was resolved.

Note that I had the same issue with a number of leftover old fonts. I was able to clean them all out in FontBook with "Look for enabled duplicates..."

-1

This looks to me like a rendering bug rather than a feature. I would try increasing the font size on your terminal.

  • No rendering error, only happens inside terminal and I can't execute the comand I want since de l and the / merge making another character – BDB88 Jul 11 '16 at 20:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .