1

We have our Apple TV 4 connected to a projector and we're using an Airplay speaker. Upon wake-up the Apple TV defaults to the physical audio output; we have to switch it to the Airplay speaker each time.

Is there a way to persist the Airplay speaker choice so that the Apple TV keeps using it upon wakeup/startup?

  • I've been investigating a similar issue and some insight appears to be that the ATV looks for a speaker connection before it looks for a network connection, thus defaulting to an internal speaker when it wakes. I've sent a bug report in to apple, but this has been an off and on problem since version 4 was released. – quip Jul 5 '16 at 2:07
  • Same problem here. Any news on your side, guys? Little issue, but totally ruins my user experience (and unfortunately seems very symptomatic in my growing list of Apple annoyances) – qqilihq Oct 29 '16 at 19:05
  • I opened a radar with Apple and it was closed as a duplicate so Apple knows about this issue and will hopefully fix it in tvOS updates. – Fred Clausen Oct 30 '16 at 2:00
1

As this issue still persist in 2019, wanted to add a temporary solution.

Big thanks to the answer from user quip above that pointed in the right direction: the Apple TV checks for Speakers before looking for a Network Connection.

The semi-solution is to set the Network Connection on the Apple TV to Manual.

Go to Settings > Network > Ethernet > Configure IP and select Manual.

You can just click on "Done" on all the prompts if you want to use the same settings as before.

After this fix, most of the time, the Apple TV remembers the AirPlay Speaker selected after wakeup.

Update: Here is a step-by-step video tutorial for the procedure: https://youtu.be/wb4-U0TUB0Y

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .