0

I have an early 2009 Mac Pro and a FireWire audio interface that I haven't used in a couple of years. I just plugged it in to the Mac and nothing happens. The device doesn't get power, and even if I connect external power to the device the system still doesn't see it. I found an article online that said to try resetting the NVRAM. I did that but the problem still exists. This is the only FireWire device I have and I only have one cable, so I don't have a way of seeing if the problem is the device or the cable. Does anyone have any ideas about how to track down the problem? Is there some way I can see if the FireWire ports are functioning without a device? (I did try all 4 ports.)

  • Try Apple Hardware Test (AHT). Hold the D key while booting from a powered off state with the AC adapter connected. See if it gives you an error code and edit your question with the results. – Allan Jul 5 '16 at 0:32
  • I tried this several times and can't get anything to happen. I unplugged everything except my keyboard and monitor, shut down, started power up and held the D key right away. All I see is the gray screen and eventually the system boots as usual. Is there some trick to this? – Andy Schweig Jul 17 '16 at 21:43
  • Your hardware test software may be on Disk 2 of your OS X installation media. Do you still have these available? – Allan Jul 17 '16 at 23:45
1

You can lookup connected FireWire devices in the Apple system profiler under Hardware > FireWire

Open the System Information or System Profiler app from the Utilities folder of your Applications folder. Or just hold down the Option key while choosing System Information or System Profiler from the Apple menu.

Most FireWire devices will show up out of the box. FireWire audio devices usually require additional third party driver software.

  • The device doesn't show up in System Information. To clarify, I've used this audio interface on this Mac before and the software for the device is still there. I'm running Yosemite now and was probably running Mavericks last time I used the device. I hadn't updated the driver software when I made my original post but I just did it and the behavior is the same. Also, even if if the device isn't recognized, shouldn't it at least be getting bus power? And shouldn't the system say that there's something there even if it doesn't have the right software? – Andy Schweig Jul 4 '16 at 23:19
-1

Definitely check the driver for the interface. Download the most recent version from the website (the brand of interface i.e., Focusrite, Presonus, etc...). Hope this helps!

  • How would a device driver have anything to do with the device not getting power connected to external power? – Allan Mar 13 '18 at 13:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .