3

I don't have animation for Mission Control anymore. It seems that it has been like that for few days. I have updated Duet a few days ago, maybe that's related...

What happened? Is it possible that someone disable it? Or, is it a bug or the sign that the hardware is damaged?

OS: 10.11.5 Hardware: MacBook Pro (2,3 GHz Intel Core i7, 16 Go, Intel HD Graphics 4000 1536 Mo)


Edit

I've tried to do in the terminal

defaults write com.apple.dock expose-animation-duration -float 0.25

then press enter

killall Dock

then press enter

It works. But when I restart the computer, it does not work anymore.


I've tried installing Duet (third party software which I suspected to be responsible). It did not change anything.

Edit 2

I've tried uninstalling Duet (third party software which I suspected to be responsible). It did not change anything.

  • 1
    You could try to make a new user and see if it's happening there. If it's not happening there, then it could be that a third party application is resetting the animation speed or causing some sort of error. – Joonas Jul 5 '16 at 12:56
  • This problem does not occur for other users on my computer, you were right. – Colas Jul 5 '16 at 13:05
  • I'm actually kind of out ideas. I can't remember if it's normally animated in the safe mode. That is something you could try. You could then try to open suspected apps to try and figure out which application is causing it... Maybe. – Joonas Jul 5 '16 at 22:00
  • The animations are already disabled when I restart (or turn on) the computer. – Colas Jul 6 '16 at 11:08
  • Try resetting your dock back to it's original configuration. Go to ~/Library/Preferences and mv com.apple.dock.plist ~/.Trash; killall Dock That will bring your Dock back to the state when you first created your account so you will have to re-customize. If it doesn't work, you can "undelete" from the Trash – Allan Jul 14 '16 at 17:43
1

Try resetting your dock back to it's original configuration. This will involve deleting the com.apple.dock.plist file so that when the Dock is reloaded it will create a new dock as if this is the first time you are logging in. This means you will have to redo all your customizations

Go to ~/Library/Preferences and execute the command:

mv com.apple.dock.plist ~/.Trash; killall Dock

That will bring your Dock back to the state when you first created your account so you will have to re-customize. I opted to move the files to trash, so that if you want to go back, you can restore from Trash and everything will be the way it was before you started.

However, if you just want to delete the file permanently, you could also issue the command (there's no going back with this one):

rm com.apple.dock.plist; killall Dock

Reboot, and all should be working again.

3
+50

I too, have Duet installed and lost Mission Control animations on last update.

I believe it's some lazy "bug fixing" on Duet's team: Duet was running and I got logged out of my Mac

defaults delete com.apple.dock expose-animation-duration

then run Duet and then

defaults read com.apple.dock expose-animation-duration

It's again gets set to zero.

So my solution so far is deleting expose-animation-duration setting and removing Duet from autostart for a time being.

1

If the Terminal commands mentioned above give you the animation back, you could try putting them in a script file and having it run as a login item.

First, open Script Editor. Hit ⌘N to make a new document window, and in that window paste the following AppleScript script:

do shell script ¬
"defaults write com.apple.dock expose-animation-duration -float 0.00" & ¬
"defaults write com.apple.dock expose-animation-duration -float 0.25" ¬
& return & ¬
"killall Dock"

Next, click File > Export. At the bottom of the save dialogue, choose Application as the file type. It doesn't really matter where you save it to, as long as you will know where it is later.

Next, go to System Preferences > Users & Groups. Click on your user account, and go to the Login Items tab. Click the plus button at the bottom of the list, navigate to your new application and click the Add button. Now, whenever you log out and back in or restart your computer, this script will be run, (hopefully) fixing your Mission Control animations.

As to exactly why this might be happening, I honestly have no clue. Never had this issue before.

1

You can try making the commands that made it work run at startup. So just open TextEdit, type

#!/bin/bash
defaults write com.apple.dock expose-animation-duration -float 0.25
killall Dock

Then save it as whatever (just make sure it either has no extension or that the extension is .sh or .command), open System Preferences, go to Users & Groups > Login Items, and add it to there.

0

Remove Duet from your login items, then type defaults write com.apple.dock expose-animation-duration -float 0.25;killall Dock.

It is a bug in Duet. Do not use it for a while.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .