0

I'm using a USB device that combines a few inputs(optical, USB, 3.5mm) and outputs them to one 3.5mm port. After outputting my MacBook Pro sound to the device through USB for a few minutes there appears noise and not long later it becomes so unbearable that I have to pause the media. That cycles every 3-5 minutes provided that I output it through USB. If I output through the 3.5mm jack, however, everything is smooth. I tried using the device on a Windows computer and outputting through USB worked fine. I also recorded the outputted audio(screenFlow) and there was no noise there.

  • To clarify, the noise is coming from speakers connected to the USB adapter? And you can only hear it if audio media is playing? – victor Jul 4 '16 at 15:31
  • I connect headphones, not speakers, to the USB adapter but I've used the headphones without the USB device, through the 3.5mm port and they've worked fine. Yes, it is only heard if media is playing. – John Jul 4 '16 at 15:34
  • Could you provide a product link to the USB adapter you are using? – victor Jul 4 '16 at 15:40
  • astrogaming.com/mixamp™-pro-tr/MixAmp-TR.html – John Jul 4 '16 at 15:41
  • Thanks. Is it the same problem for any media? ex. iTunes music, YouTube, video games – victor Jul 4 '16 at 15:53
1

Sounds like a problem with the audio format. Open the Audio MIDI Setup application, select your USB device, and try different combinations for audio format (sampling rate, channel/bit-depth).

audio format settings

If your device is locked at a sample rate and/or bit-depth, this should be a workaround. Try creating a Multi-Output Device with your device and the Built-in Output. (note: with the multi-output, you will have to set the volume on each device individually)

enter image description here

  1. Click the + icon at the bottom left and select Create Multi-Output Device.
  2. Under the "use" column, select Built-in Output and your device.
  3. Set the Master Device to Built-in Output. This will allow you to choose different sample rates based on what is allowed for Built-in Output.
  4. Lower the volume on Built-in Output (essentially muting it so sound only goes through your device)
  5. Right-click on your device under the Multi-Output Device and check Resample this subdevice.
  6. In System Preferences > Sound, change the output device to the Multi-Output Device.

Now you can change the sample rate of the multi-output device.

  • The Audio MIDI Setup didn't provide different formats - just 48000.0 Hz and 2ch-16bit Integer. – John Jul 4 '16 at 17:06
  • Updated answer with a workaround. – victor Jul 4 '16 at 17:42
  • I tried changing the sample rate through your workaround, however the noise still appears. It seems like it takes longer but it definitely is still there. – John Jul 4 '16 at 18:49
  • Looks like we're heading in the right direction. Which sample rate(s) seemed to lessen the noise? – victor Jul 4 '16 at 19:35
  • 48000.0 Hz seemed the longest until noise appeared. – John Jul 4 '16 at 19:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .