0

I have a USB2, 500GB external hard drive that I use for Time Machine backups. In order to test something, I created a new partition in the drive, roughly 30GB in size. Once I was done with my tests, I wanted to delete the partition and merge the free space back to the original, larger partition. When I deleted the small test partition with Disk Utility, I encountered an error. A pop-up indicated that I should try to repair the disk, and that I did. Afterwards, the old partition appears as free space, but when I try to create a new partition on that free space (and it doesn't matter which kind of file system), I hit "apply" and the partition isn't created. When I try to move to a different tab in Disk Utility, it warns me that there are unsaved changes.

This is my diskutil output:

Asafs-MacBook-Pro:~ asafchelouche$ diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *251.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage                         250.1 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           *249.8 GB   disk1
                             Logical Volume on disk0s2
                             <intentionally left out>
                             Unencrypted
/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:          Apple_CoreStorage                         464.7 GB   disk2s2
   3:                 Apple_Boot Boot OS X               134.2 MB   disk2s3
/dev/disk3
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Asaf's Time Machine... *464.4 GB   disk3
                             Logical Volume on disk2s2
                             267758BA-8C0B-4710-B626-1909F9126576
                             Unlocked Encrypted

Note: the free space is right after the currently functioning partition, and it spans all the way to the disk's end.

What should I do in order to create a partition on the hard drive, so I could merge it back into the larger partition?

EDIT: I've followed this post, but to no avail: when trying to execute the following command:

sudo gpt add -b 908317520 -i 4 -s 68390024 -t 48465300-0000-11AA-AA11-00306543ECAC disk2

I get this error message: gpt add: unable to open device 'disk2': Resource busy. I guess this is the same error that is returned to Disk Utility's GUI when I tried to create a new partition. Any thought on how to "un-busy" the device? (I executed diskutil umountDisk /dev/disk2 in advance, and the requested partition size is divisible by 8)

P.S. This is the output for sudo gpt -r show /dev/disk2:

      start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
     409640  907645736      2  GPT part - 53746F72-6167-11AA-AA11-00306543ECAC
  908055376     262144      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  908317520   68390031         
  976707551         32         Sec GPT table
  976707583          1         Sec GPT header
0

ElCapitan? If yes: startup in the RecoveryPartition (CMD+R): Open DiskUtility from the Utilities menu, Select your disk, then the Partition bar, move the slider to make the main partition to take all space... Then apply and close DU. Restart. See the picture: enter image description here

  • I'm using Yosemite 10.10.5. I tried booting into recovery mode, but I encountered the same problem. Could this be due to the fact that the disk is encrypted? – asafc Jul 4 '16 at 16:57
0

So, to conclude, the solution was to completely erase the external drive, re-partition and copy back the data.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .