How can I get BOOTCAMP to be listed under Devices in Finder so that I can go into it and view the files there?

I can boot into BOOTCAMP as normal on startup but in OS X, Finder does not list BOOTCAMP.

It used to in OS X versions previous to OS X El Capitan, but I'm not sure exactly when it stopped showing and whether or not it's the OS X El Capitan upgrade or something else that caused the issue.

Here is the screenshot showing that BOOTCAMP is not listed in Finder:

Finder with Bootcamp not listed and settings

Disk Utility shows the Macintosh HD and BOOTCAMP partitions, but only lists Macintosh HD on the left beneath the overall drive (Samsung 840 Pro SSD). Here is a screenshot showing this:

Disk Utility showing Macintosh HD and BOOTCAMP partitions but only listing Macintosh HD in left hand list

sudo frisk /dev/disk0 command issued in the Terminal gives the following:

Roberts-MacBook-Pro:Volumes robdavishome$ sudo fdisk /dev/disk0
Disk: /dev/disk0    geometry: 62260/255/63 [1000215216 sectors]
Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
 1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>
 2: AF 1023 254  63 - 1023 254  63 [    409640 -  640270848] HFS+        
 3: AB 1023 254  63 - 1023 254  63 [ 640684032 -    1269536] Darwin Boot 
*4: 07 1023 254  63 - 1023 254  63 [ 641953792 -  358260736] HPFS/QNX/AUX

Here is the output from sudo gpt -r show /dev/disk0:

Roberts-MacBook-Pro:Volumes robdavishome$ sudo gpt -r show /dev/disk0
gpt show: /dev/disk0: Suspicious MBR at sector 0
       start        size  index  contents
           0           1         MBR
           1           1         Pri GPT header
           2          32         Pri GPT table
          34           6         
          40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
      409640   640270848      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
   640680488        3544         
   640684032     1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
   641953568         224         
   641953792   358260736      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
  1000214528         655         
  1000215183          32         Sec GPT table
  1000215215           1         Sec GPT header

I don't have gdisk installed.

My Setup

  • MacBookPro mid 2010 17"
  • Mac OS X El Capitan 10.11.5
  • Samsung SSD 840 Pro
  • Windows 10 Pro 64bit (in-place Microsoft standard upgrade from Windows 7 Pro 64bit)
  • I adjusted the size of the partitions using Camptune X when I had Yosemite
  • My adjustment was to create some unpartitioned space at the end of the SSD for over provisioning (to apparently enhance the life and performance of the SSD). I reduced the size of the Mac OS partition and shifted the Windows partition to take up the space created by the shrinking of the Mac OS partition, so that some unpartitioned space was left at the end.

Research so far

Please can I have advice on how to get BOOTCAMP to be shown in Finder.

  • 1
    Please add the output from sudo gpt -r show /dev/disk0 – David Anderson Jul 2 '16 at 23:45

Solved - the answer is that Windows was in a hibernate state. I was able to take Windows out of this state and now BOOTCAMP appears. I will accept my own answer when I am allowed to. More details of solution below.

I downloaded a trial of Paragon Disk Manager which showed the BOOTCAMP partition and provided an option to mount it. On attempting to mount, a dialogue popped up saying that the Windows operating system was in hibernate state and that it could not be mounted by accessing the partition by read-only operations; some write options would be required. I think an option was provided to proceed, but instead I decided to boot into Windows from start up as usual and attempt to fully and properly shut it down (as this is the least risky approach; better to get Windows to sort itself out regarding fully shut down and out of hibernate mode rather than from externally (i.e via an app in MacOS). There were some routine Windows updates ran but I don't think this is relevant. So after having shut Windows down. I started up into MacOS and can now see BOOTCAMP in finder. I don't work for Paragon or have any financial or otherwise interest in them, but the tool served a good purpose in that I could attempt to mount the partition which lead me to the solution.

I've seen something like this with dual-boot Windows / Ubuntu (Linux) systems whereby Ubuntu warns of same message about Windows being in a hibernate state when attempting to mount the Windows partition. So from that I conclude that the issue is not rare (and fortunately remediable). Ubuntu warns that attempting to mount is risky as it means it would have to modify the partition in order to mount it. Again it's therefore better to boot into Windows and fully shut it down. Not really sure why Windows would ever be hibernate mode when shut down though, but a "power cycle" seemed to get it out of this mode and into a fully shut down state.

So that's solved. However as a separate perhaps unrelated point I am concerned about the gpt show: /dev/disk0: Suspicious MBR at sector 0 message seen when running sudo gpt -r show /dev/disk0 as stated above. Any tips would be welcome, but my machine functions perfectly fine so this does not appear to affect it but I'd like to resolve this message anyway - research so far doesn't give a definitive answer it seems, I may write another question.

  • 1
    Normally, when a disk is using the GPT partitioning scheme, the 2nd, 3rd and 4th partitions in the MBR table are empty. Also, the 1st partition spans the entire disk (except for the MBR itself). In your case, in order for Windows to be installed, these conditions have not been met. The message is correct in the fact that the gpt command finds something *suspicious`, but is is normal for your model Mac and you should not be concerned. – David Anderson Jul 3 '16 at 4:50
  • +1 upvote David for your further input and reassurance, thank you! So it seems that this perhaps "false positive" message about suspicion is specific to the particular model I am using? I would guess it's not seen on some other Mac models. I certainly appreciate your input and want to follow your advice. Any background or links would be of interest to expand my knowledge, part out of enhancing my overall knowledge but also general perhaps irrational paranoia tendency I have. Thank you again. – therobyouknow Jul 3 '16 at 9:52
  • 1
    This error message occurs on all Mac models dated 2011 or earlier which also have Windows installed. The message can also occur on Mac models dated 2012 through 2014 depending on how Windows is installed. For 2015 and newer Mac's, this message should not occur when OS X and Windows are the only operation systems installed. In other words, the error message indicates your Mac is using what is referred to as the hybrid partition scheme. – David Anderson Jul 4 '16 at 5:23
  • +1 thanks David for the additional information, most appreciated! – therobyouknow Jul 4 '16 at 12:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .