0

It isn't only on iOS 9.3.2, it's been happening since the later iOS 8 versions. But for some reason, I haven't been able to update a certain app on my iPod 6th generation for a while now.

The app indicates that it's preparing for an update when I tap on update. After a few seconds though, it reverts back to the update button.

I've tried...

  • Restarting my device
  • Using "update all" instead of updating the app by itself.
  • Pressing on the update button several more times to see if it would begin updating.

But none of these have actually worked.

As said in the title, this only currently happens for one app. All of the others work fine.

If anybody could help me with this, that'd be great. This issue has been bothering me for a while now.

  • Is the app still available for sale in the App Store? – fsb Jul 2 '16 at 19:53
1
  1. Remove the corrupted iOS app from your iOS device ( be sure to backup data prior step 1)
  2. Shutdown your iPhone/iPad
  3. Restart iOS
  4. Reinstall the app from the AppStore
  • That's the thing, I don't want the data from the app to be deleted. Any way to do this? – Zachary Vincze Jul 2 '16 at 0:39
  • I can't give you a exact answer on this because I don't know which app you are using. It depends on your iOS app. In some cases you are able export/import your settings. – howdytom Jul 2 '16 at 0:44
  • The game had a cloud saving system that I wasn't aware of. Problem solved! – Zachary Vincze Jul 2 '16 at 22:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .