When I restart my computer it tries to restore my open Preview PDFs. Clearly I opened them (and I've tried every which way to do that so the whole new sandbox methods will retain permission), and yet I keep getting it.

I nuked the Saved State Folder (which oddly is the only app, Apple or 3rd, with a symlink to within its Container…) and it went away for a bit. But I just got it again. Oddly though it was only for half the open files. (five PDF whitepapers open in one window, sitting in the same folder, three opened, 2 gave Permission Errors)

Any ideas? It keeps restoring because every time I close the laptop it goes into deep sleep immediately. I have no idea if this is a fluke on my machine or a Lion thing. Upon wake up it just stalls and then does an entire reboot — thus trying to restore everything that was open from before.

Despite that having its own degree of obnoxiousness at times, it's somehow worse when it does it but fails. And it makes no sense to me that it'd only fail on some files and not others, especially when they're sitting in the same folder. The sandbox permission shouldn't relate to the Saved State restore, anyway.

  • Probably a dumb question, but have you tried repair permissions via Disk Utility? Commented Sep 15, 2011 at 14:59

1 Answer 1


To solve the permission errors, just boot from your recovery cd(insert cd and reboot while holding alt/option) and click in the menubar on 'Utilities' and select 'Disk Utility'. When you are there, you can choose 'repair disk permissions' (get ready for about 2 hours of not being able to use your computer).

In preview, close each document and then quit the app, that should do the trick.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .