1

I have bought a new Samsung EVO 850 SSD, it is yet unformatted. I have a SATAI/II to USB3.0 dock which I want to use to get the drive formatted, but it is just not showing up in Disk Utility (Recovery mode or plain) or even Disk Management on Windows. I have a Macbook Pro 17" Early-2011 [El Capitan 10.11.5] and want to clone my current HDD to this SSD using Carbon Copy Cloner.

The dock I am using is this exact one: https://www.amazon.com/Vantec-3-5-Inch-Drive-Black-NST-D300S3-BK/dp/B007B5PQW4

The SSD is this one: http://www.samsung.com/za/consumer/memory-storage/memory-storage/ssd/MZ-75E250BW

I have read of a few people successfully installing this drive into their Macbook Pro, but success eludes me.

Is the drive maybe broken? Or is the dock preventing the drive from showing up? Or am I doing something wrong.

-1

The first thing to do with any SSD problems, is check that the drive has the latest firmware. I had an Intel SSD that was simply not seen on a Mac, but worked fine in a PC. I upgraded the drive's firmware, and now the Mac can see the drive, and even boot from it.

Find the latest firmware for the drive, and try applying it.

NOTE: updating the firmware on an SSD usually wipes all the data on it! I know you said that it is currently uninitialised and unused, but please be aware of this before attempting a firmware update.

  • Just checked, there are currently no firmware upgrades for this drive. – Anriëtte Myburgh Jun 29 '16 at 10:00
  • Oh well, it was a good idea ... – Scott Earle Jun 29 '16 at 10:01
  • If you plug the drive internally in the 17" MacBook Pro, can the computer see the drive? That would eliminate the dock from the chain, at least. – Scott Earle Jun 29 '16 at 10:05
  • I think that it might be the cause, yes, because I plugged it into my friend's Windows and wiggled the drive, and something showed up, but then disappeared after a few seconds. So I'm guessing my dock's connector on the inside is iffy – Anriëtte Myburgh Jun 29 '16 at 10:09
  • 1
    So it was the dock that was faulty, bought a simple SATA to USB2 adapter at the local cabling shop and it immediately showed up when I plugged in the drive. – Anriëtte Myburgh Jun 29 '16 at 12:07
4

Old thread, but just run to similar problem myself. My old HDD broke up, and had no chance to format my new SSD anywhere.

New disk was not listed on Disk Utility, when booted the machine with USB-installer and so that I was not able to format the disk and I was not getting nowhere.

I noticed that I was able to run Terminal during installer (Top ribbon)

I checked all devices with command-line Disk Utility:

diskutil list

And the new Disk was listed there.

Then format using diskutil:

diskutil eraseDisk JHFS+ NewDisk /dev/<disk id>      

The new disk was formatted and reboot. Disk was now listed on Disk Utility and I was able to install the macOS without issues.

  • These 2 commands will work within a normal session in case the internal HDD is not broken. – dan Aug 10 at 11:01
1

Same issue with new Samsung EVO 860 in 2011 MacBook Pro. In Terminal I typed:

diskutil eraseDisk JHFS+ NewDisk/dev/0.

Next, I quit Terminal, launched Disk Utility, and then was able to see the new disk in Disk drive.

0

I had the same issue - bought a new Samsung EVO 860 SSD for my early 2011 MacBook Pro 13 inch running OS X Yosemite.

The original HDD was still working (but painfully slow), so i had intended to use a SATA III to USB3.0 dock to clone the HDD to the new SSD prior to removing the old HDD and installing the SSD.

Put the new SSD in the dock, connected dock to MacBook Pro, but the SSD was not being recognised at all in Finder or in Disk Utility.

I also tried it on another notebook running Windows 10, and it was not recognised as a disk on Windows - when i plugged the dock into the Windows notebook, a message came up identifying it as a faulty USB device, but I could not see it as a disk in Disk Management on Windows.

In the end, I did what anrah has mentioned above. Installed the "blank" SSD into the MacBook Pro, booted MacBook Pro into Recovery mode and then used Terminal prompt to format the SSD using the diskutil eraseDisk script. When running the "diskutil list" the blank SSD just comes up as an unnamed, unformatted drive (key is to check it is the correct disk by looking at the capacity ie. mine is 500GB so it came up as an unnamed 500GB disk).

After running eraseDisk (which takes about 5 seconds) the SSD was then "recognised" by Mac OS as a disk.

I then restored to the new SSD from most recent Time Machine backup on an external disk. That all seems to have worked.

As this seems to be a common issue for both Mac OS and Windows users for the newer SSDs, it is curious that manufacturers do not ship the new SSDs pre-formatted (whether in Mac OS Extended, NTFS, FAT32 or whatever) as a formatted disk will at least be recognised as a disk when first connected to either Mac OS or Windows.

0

My answer will be helpful for those who are upgrading their SSD. Personally, I had a MacBook air early 2015 with 128 GB SSD. While upgrading to 512 GB SSD, it was not detected in the internet recovery mode. I tried both Disk Utility and Terminal commands. Finally, this method helps me to fix the issue. https://techiestechguide.com/internal-ssd-is-not-showing-in-macbook-while-booting/ NB: It will work with any brand SSD.

  • 1
    Welcome to Ask Different! While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – Tetsujin Aug 10 at 8:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .