-1

I am trying to upgrade my svn version. So I deleted older binary

sudo rm /usr/bin/svn

Then I installed svn

brew install svn

And linked it too

athakur:home athakur$ brew link --overwrite subversion
Warning: Already linked: /usr/local/Cellar/subversion/1.9.4
To relink: brew unlink subversion && brew link subversion

But when I do svn --version it says

athakur:home athakur$ svn
-bash: /usr/bin/svn: No such file or directory

Any idea how do I restore new svn binary?

  • Well home-brew won't update or change anything in /usr/bin what directory does Homebrew documentation say it will be in? – Mark Jun 28 '16 at 17:52
  • @Mark looks like it is in /usr/local/Cellar/subversion/1.9.4/bin – Aniket Thakur Jun 28 '16 at 17:55
  • See the related questions – Mark Jun 28 '16 at 17:55
0

Here are the SVN binary packages: https://subversion.apache.org/packages.html

I had previously faced a similar issue and this solved the issue for me.

Also, when I tried using brew I had an issue, so I used MacPorts.

0

Looks like homebrew installed svn in

/usr/local/Cellar/subversion/1.9.4

So I added it in $PATH

export PATH=$PATH:/usr/local/Cellar/subversion/1.9.4/bin/

Added it in ~/.bash_profile. Then execute -

source ~/.bash_profile

and all seems good again

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .