0

Here is the problem.

A long time ago, I set my Mac Mini to dual boot (using Bootcamp, but with some third-party repartitioning).

I proceeded to install rEFInd, and eventually, to triple-boot. To find the right combination of partitions was a bit tedious, but I got it to work (using a GPT with a protective MBR disk layout, and a number of partitions, for recovery, for each system - three for Windows, two for OSX, one for Ubuntu Linux).

All was well initially, I could boot to rEFInd, and then move around and boot around as well.

BUT. One fine day, shortly after, my computer stopped detecting the internal HDD at boot time.

I'd get the blinking grey folder. I got out of it by booting from a Linux Live CD, every time, then restarting my way to the rEFInd partition.

That's right: after the Linux Kernel initial load, the whole computer sees the internal HDD once again.

I have tried:

  1. Setting the boot HD in MacOSX, from "System Preferences".
  2. Repairing file systems using Disk Utility, and also, using Onyx.
  3. Resetting the NVRam and whichever equivalent of the PRam, using the reserved key combinations at startup + actions involving removing the power cable.
  4. Completely reinstalling, repartitioning.
  5. Reinstalling OSX over the network, not using any boot media.

To no avail.

I am now running two systems, Ubuntu and OSX El Capitan, but to this day - and hear me out, the whole hardware is running fine, has been running for over a year just fine - yet, to this day, whenever I shut my Mac down, I have to resort to the Live USB procedure to gain access to rEFInd.

I am looking for:

  • A way to boot into the supposedly programmable firmware? Tests I can run there?
  • A cure?
  • A way to boot from a nice, special type of USB image (UEFI or otherwise) that pipes me back into my HDD without the whole Live CD shenanigans.

In advance thank you.

1

Try disabling System Integrity Projection. From what I've seen rEFInd doesn't play as well with El Capitan as it has with older versions.

Follow the steps here: http://mattjanik.ca/blog/2015/10/01/refind-on-el-capitan/

  • Thank you for the information, but the issue happens before rEFInd is loaded. I tried though, booted from an install media, disabled SIP, made sure no firmware password was set. No dice. – Mauro Colella Jun 29 '16 at 2:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .