It seems like I cannot execute AppleScripts on my Mac.

I am running OS X 10.7.1 and when I try to compile an AppleScript, even a script as simple as display dialog "Hello World!", I get a syntax error.

In the preferences for the AppleScript editor there nothing in the Default Language drop down menu on the General preferences page.

Does anybody know what might be wrong? Is it possible to reinstall just AppleScript?

  • 2
    As a data point: display dialog "Hello World!" worked for me in my AppleScript editor on 10.7.1. I have one entry in my drop down for Default Language: AppleScript (2.2). – Ian C. Sep 7 '11 at 18:31
  • hmmm, i assume you have tried running lion from a recovery disk and making sure the startup disk is okay? Do you have XCode installed? – lemonginger Sep 7 '11 at 21:57
  • 2
    So problem fixed after restart without "resume" feature:) – simekadam Sep 8 '11 at 11:43

So actually the problem has been solved by restarting my Mac with "resume" feature turned off.

  • This seems most unusual, can I ask you to turn ot on again, and see if it re-occurs? – stuffe Feb 22 '12 at 16:28
  • I meant "by restarting with resume checkbox unchecked"..As far as remind on that issue, I had tried lot of restarts, but with resume on, and probably there was some problem cached or something like this. But then I did proper restart and afterwards it has been working ok..And it still is:) – simekadam Mar 2 '12 at 17:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .